Actualización de la versión de PHP en Debian

Created:

2016-11-16 12:51:27 UTC

Modified:

2017-05-22 14:58:17 UTC

14

Was this article helpful?


Have more questions?

Enviar una solicitud

Actualización de la versión de PHP en Debian

Consulta

¿Cómo puedo actualizar la versión de PHP instalada en Debian a la versión 5.4, 5.5 o 5.6?

Respuesta

Importante : oficialmente, Plesk soporta los paquetes incluidos en el software, paquetes de sistema y paquetes de repositorios oficiales de sistema.

Si su sistema no dispone de las versiones más recientes de los paquetes de PHP de los repositorios oficiales, compílelo de forma manual o instálelo a través de repositorios de terceros.

Este tipo de actualización de PHP es puramente una tarea administrativa y debería ser llevada a cabo por su administrador local. Esta operación no se encuentra dentro del ámbito de soporte de Plesk.

A continuación puede ver un ejemplo de cómo actualizar su versión de PHP en Debian mediante un repositorio de terceros:

  1. Añada el repositorio principal a su lista de orígenes:

    En función de su distribución (Jessie, Wheezy o Squeeze), añada las siguientes dos líneas a su archivo /etc/apt/sources.list . También puede seleccionar un mirror cercano a usted.

    deb http://packages.dotdeb.org jessie all
    deb-src http://packages.dotdeb.org jessie all

    O bien:

    deb http://packages.dotdeb.org wheezy all
    deb-src http://packages.dotdeb.org wheezy all

    O bien:

    deb http://packages.dotdeb.org squeeze all
    deb-src http://packages.dotdeb.org squeeze all
  2. Opciones

    Si desea instalar:
    PHP 5.6 en Debian 7 “Wheezy” (sin Zend Thread Safety), añada también las siguientes dos líneas:

    deb http://packages.dotdeb.org wheezy-php56 all
    deb-src http://packages.dotdeb.org wheezy-php56 all

    PHP 5.6 en Debian 7 “Wheezy” (sin Zend Thread Safety), añada estas dos líneas en su lugar:

    deb http://packages.dotdeb.org wheezy-php56-zts all
    deb-src http://packages.dotdeb.org wheezy-php56-zts all

    PHP 5.5 en Debian 7 “Wheezy”, añada también las siguientes dos líneas:

    deb http://packages.dotdeb.org wheezy-php55 all
    deb-src http://packages.dotdeb.org wheezy-php55 all

    PHP 5.4 en Debian 6 “Squeeze”, añada también las siguientes dos líneas:

    deb http://packages.dotdeb.org squeeze-php54 all
    deb-src http://packages.dotdeb.org squeeze-php54 all
  3. Recupere e instale la llave GnuPG

    wget http://www.dotdeb.org/dotdeb.gpg
    sudo apt-key add dotdeb.gpg
  4. Proceda con la actualización

    apt-get update  
    apt-get install php5

Nota : las versiones de PHP que no aparecen en la lista deberán compilarse de forma manual. En el caso de experimentar cualquier incidencia con la compilación o instalación de PHP a través de repositorios de terceros, consulte la documentación de PHP o póngase en contacto con su administrador local para obtener asistencia.

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.