Error en la actualización si se ha instalado una versión anterior del paquete mysqlclient15

Refers to:

  • Plesk 10.4 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 10.3 for Linux

Created:

2016-11-16 12:50:54 UTC

Modified:

2016-12-21 19:21:59 UTC

0

Was this article helpful?


Have more questions?

Enviar una solicitud

Error en la actualización si se ha instalado una versión anterior del paquete mysqlclient15

Síntomas

Si se actualiza MySQL mediante el repositorio Atomic y se tiene instalada una versión anterior del paquete mysqlclient15, la actualización puede que no se complete y devuelva el siguiente mensaje de error:

Upgrade fails with the error: 
Trying to set up APS controller database... Attempting to check APS db
connection via ODBC, using /usr/bin/isql (empty output is good)
/usr/bin/isql: relocation error: /usr/lib64/libmyodbc3.so: symbol strmov, version libmysqlclient_15 not defined in file
libmysqlclient.so.15 with link time reference
Failed, rc = 127.
Failed to establish test connection. Cleaning up.

ERROR while trying to establish test connection to APS database via ODBC
Check the error reason(see log file:
/tmp/plesk_10.4.4_installation.log), fix and try again

Causa

La causa de esta incidencia es un error en el paquete mysqlclient15 del repositorio Atomic que se instaló junto con el paquete MySQL de Atomic.

Resolución

Actualice el paquete mysqlclient15 a la versión más reciente. Ejecute el siguiente comando:

# yum update mysqlclient15

La versión del paquete que incluye la corrección de esta incidencia es la "mysqlclient15-2.el5.art."

Puede comprobar la versión del paquete mysqlclient15 ejecutando el siguiente comando:

# rpm -q --queryformat '%{RELEASE}\

' mysqlclient15 2.el5.art

A continuación, vuleva a ejecutar la utilidad bootstrapper para completar la actualización:

/usr/local/psa/bootstrapper/pp -bootstrapper/bootstrapper.sh repair

Reemplace por la versión actual presente en su servidor, como por ejemplo /usr/local/psa/bootstrapper/pp11.0.9-bootstrapper/bootstrapper.sh .

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.