Posibles problemas con dist-upgrade

Created:

2016-11-16 12:49:37 UTC

Modified:

2017-07-20 22:17:17 UTC

6

Was this article helpful?


Have more questions?

Enviar una solicitud

Posibles problemas con dist-upgrade

Dist-upgrade no es un proceso simple. Para llevarlo a cabo debe tener una amplia experiencia en la administración de sistemas, además del conocimiento necesario del sistema y de sus componentes. Durante o tras la realización de dist-upgrade puede que experimente algunas incidencias que pueden resolverse tal y como se detalla en este artículo.

Antes de iniciar dist-upgrade, lea las indicaciones proporcionadas en la documentación del proveedor del sistema operativo: Debian 6 a Debian 7 Debian 7 a Debian 8 Ubuntu 12 a Ubuntu 14

Con el fin de evitar posibles problemas, realice los pasos descritos en este artículo .

Índice de contenidos

Errores generales durante dist-upgrade

  • El paquete Plymouth presenta dependencias unmet

    Dist-upgrade resulta fallido debido al siguiente error:

        # apt-get dist-upgrade 
    Reading package lists...
    Done Building dependency tree
    Reading state information...
    Done Calculating upgrade... Failed
    The following packages have unmet dependencies:
    udev : Breaks: plymouth (< 0.9.0-7) but 0.8.5.1-5 is to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    El paquete 'plymouth' presenta dependencias unmet.
    Elimine este paquete y efectúe dist-upgrade de nuevo.

  • No pudo realizarse una configuración inmediata

    Dist-upgrade resulta fallido debido al siguiente error:

    E: Could not perform immediate configuration on...

    Ejecute lo siguiente:

    # apt-get dist-upgrade -o APT::Immediate-Configure=0
  • Error al obtener la conexión D-Bus

    Tras efectuar dist-upgrade, algunos servicios no pueden iniciarse debido al siguiente error:

    Failed to get D-Bus connection: Unknown error -1
    Switching to 'systemd' system initialization service was not completed:

    # ps -p 1 -o comm=
    init
    1. Elimine el archivo /etc/apt/preferences.d/local-pin-init e instale el paquete 'systemd-sysv':

      # rm -f /etc/apt/preferences.d/local-pin-init
      # apt-get install systemd-sysv
    2. Reinicie su servidor.

    3. Repare los servicios de Plesk:

      # plesk repair installation
  • No existe ninguna llave pública disponible

    El comando #apt-get update muestra las siguientes advertencias:

    N: Ignoring file '50sw_autoinstaller.list.saved_by_plesk_distupgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
    W: There is no public key available for the following key IDs:
    9D6D8F6BC857C906
    W: There is no public key available for the following key IDs:
    7638D0442B90D010

Puede ignorar esta advertencia con toda seguridad. En todo caso, si desea no volver a verla, instale keyring:

    # apt-get install debian-archive-keyring
  • initscripts: Corrupción: nfs-common

    El comando dist-upgrade resulta fallido si se instala nfs-common y se obtiene el siguiente error:

    # apt-get dist-upgrade
    Calculating upgrade... Failed
    The following packages have unmet dependencies:
    initscripts : Breaks: nfs-common (< 1:1.2.5-3) but 1:1.2.2-4squeeze2 is to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    Elimine el paquete nfs-common y proceda con la actualización:

    #apt-get remove nfs-common
  • No pudo realizarse una configuración inmediata en mysql-server-5.5

    El comando dist-upgrade resulta fallido y se obtiene el siguiente error:

    E: Could not perform immediate configuration on 'mysql-server-5.5'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

    Esto sucede si se ha instalado el paquete libc6-dev , pero mysql-server requiere gcc-4.4 . Instale los paquetes que faltan para proceder con la actualización:

    # apt-get install gcc-4.4
    # apt-get install mysql-server-5.5
  • No pudo accederse al webmail de Horde

    El webmail de Horde muestra el siguiente error tras la autenticación:

    Call to a member function write() on NULL

    En /var/log/maillog pueden verse registros como los siguientes:

    Dec 18 22:03:23 testpar1 courier-imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 18 22:03:23 testpar1 courier-imapd: authdaemon: s_connect() failed: No such file or directory
    Dec 18 22:03:24 testpar1 courier-imapd: LOGIN FAILED, method=PLAIN, ip=[::ffff:127.0.0.1]
    Dec 18 22:03:24 testpar1 courier-imapd: authentication error: No such file or directory

    Repair the mail server configuration:

    # plesk repair mail
  • El script anterior a la actualización de Plesk informa de que el paquete no está actualizado

    El script previo a la actualización de Plesk para actualizar de Debian 7 a Debian 8 devuelve el siguiente mensaje:

    The following packages are not up-to-date:
    db4.8-util
    You should install the latest updates before performing dist-upgrade

    Actualice el paquete db4.8-util manualmente:

    # apt-get install --only-upgrade db4.8-util
  • Reinicio del daemon de filtro de correo de SpamAssassin: No se puede localizar NetAddr/IP.pm

    Dist-upgrade resulta fallido debido al siguiente error de SpamAssassin:

    Restarting SpamAssassin Mail Filter Daemon: Can't locate NetAddr/IP.pm in
    @INC (you may need to install the NetAddr::IP module) (@INC contains:
    /usr/share/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.20.2
    /usr/local/share/perl/5.20.2 /usr/lib/x86_64-linux-gnu/perl5/5.20
    /usr/lib/x86_64-linux-gnu/perl/5.20 /usr/share/perl/5.20
    /usr/local/lib/site_perl) at /usr/share/perl5/Mail/SpamAssassin/NetSet.pm
    line 25.

    Complete la instalación de los paquetes ejecutando el siguiente comando:

    # apt-get -f install

    Proceda con dist-upgrade:

    # apt-get dist-upgrade
  • Dist-upgrade fallido debido al paquete udev

    Dist-upgrade resulta fallido debido a un mensaje que indica que el paquete udev no puede actualizarse debido a que el kernel no está debidamente actualizado.

    Complete la instalación de los paquetes ejecutando el siguiente comando:

    # apt-get -f install

    Proceda con dist-upgrade:

    # apt-get dist-upgrade

    Repita apt-get -f install y apt-get dist-upgrade hasta que sólo se marque el paquete 'udev' como pendiente de actualización.

    Reinicie el servidor.Finalice dist-upgrade:

    # apt-get dist-upgrade
  • Algunos de los componentes esenciales de Plesk no han podido actualizarse: panel

    Tras realizar dist-upgrade de Debian 7 a Debian 8, el script posterior a la actualización /opt/psa/bin/distupgrade.helper.deb7-deb8_post.x64.sh finaliza con el siguiente mensaje:

    Some of essential Plesk components are not upgraded: panel
    You may either upgrade them manually upgrade them or rerun utility with option --skip-check-latest
    Some error during dist-upgrade post stage occurs.

    Horde también se eliminó.

    Antes de ejecutar el script posterior a la actualización /opt/psa/bin/distupgrade.helper.deb7-deb8_post.x64.sh , ejecute el siguiente comando:

    # apt-get install psa-phpfpm-configurator
  • Dependencias unmet para libmyodbc

    Durante la actualización de Debian 6 a Debian 7, aparece la siguiente incidencia de dependencias:

    # apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Failed
    The following packages have unmet dependencies:
    odbcinst1debian2 : Breaks: libmyodbc (< 5.1.6-2) but 5.1.6-1 is to be installed
    pp12.5.30-bootstrapper : Depends: plesk-mysql-server (>= 12.5.30) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    Para solucionarlo, instale el paquete odbcinst1debian2 y proceda con dist-upgrade:

    # apt-get install odbcinst1debian2
    ...
    # apt-get dist-upgrade
  • Error al configurar sasl2-bin

    Durante la realización de dist-upgrade puede que se obtenga el siguiente error:

    Setting up sasl2-bin (2.1.25.dfsg1-6+deb7u1) ...
    saslpasswd2: user not found
    dpkg: error processing sasl2-bin (--configure):
    subprocess installed post-installation script returned error exit status 20
    Errors were encountered while processing:
    sasl2-bin
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Para resolver el problema, ejecute la utilidad sasldbconverter2 y presione Enter cuando así se le pida. A continuación, ejecute lo siguiente:

    # apt-get install -f

    Una vez haya configurado el paquete sasl2-bin , proceda con dist-upgrade.

  • Rsyslog no pudo iniciarse

    # /etc/init.d/rsyslog restart
    [....] Starting enhanced syslogd: rsyslogd rsyslogd: [origin software="rsyslogd" swVersion="5.8.11" x-pid="1973" x-info="http://www.rsyslog.com"] start rsyslogd-2013:CONFIG ERROR: could not interpret master config file '/etc/rsyslog.conf'. [try http://www.rsyslog.com/e/2013 ] rsyslogd:EMERGENCY CONFIGURATION ACTIVATED - fix rsyslog config file!. ok

Reemplace la configuración rsyslog por la configuración previa a la actualización y reinicie el servicio:

    # mv /etc/rsyslog.conf.saved_by_plesk_distupgrade /etc/rsyslog.conf
# /etc/init.d/rsyslog restart
[ ok ] Stopping enhanced syslogd: rsyslogd.
[ ok ] Starting enhanced syslogd: rsyslogd.

Errores de Apache al realizar dist-upgrade

Si dist-upgrade resulta fallido sin ningún error y solo se advierte de que no se pudieron instalar los paquetes Apache, vuelva a instalar los paquetes usando el comando que se muestra a continuación para así poder ver el error o para continuar con dist-upgrade una vez corregida la incidencia:

# apt-get install -f
  • Archivo config dir.conf no activado correctamente

    El comando apt-get install -f mostraba un error relacionado con el servicio de Apache:

    Config file dir.conf not properly enabled: /etc/apache2/mods-enabled/dir.conf is a real file, not touching it.

    Reemplace 'dir.conf' por un enlace simbólico y proceda con la actualización si puede iniciar Apache:

    # ln -sf ../mods-available/dir.conf /etc/apache2/mods-enabled/dir.conf
  • Módulo API 1aclr_module1 ilegible

    La actualización no puede completarse debido al siguiente error:

    API module structure 1aclr_module1 in file /usr/lib/apache2/modules/mod_aclr.so is garbled - expected signature 4 1503234 but saw 41503232 - perhaps this is not an Apache module DSO, or was compiled for a different Apache version?

    El módulo 'aclr' no se actualizó correctamente. Esta incidencia también puede suceder con el módulo 'fcgi'. Desactive el módulo en cuestión e intente iniciar Apache:

    # a2dismod aclr
    Module aclr disabled

    Desactive 'fcgi' ejecutando el mismo comando, de ser necesario. Proceda con la actualización si puede iniciar Apache.

  • Ninguna coincidencia para el wildcard '*.conf'

    Apache no puede iniciarse debido al siguiente error:

    apache2: Syntax error on line 234 of /etc/apache2/apache2.conf: Syntax error on line 5 of /etc/apache2/conf.d/zz010_psa_httpd.conf: Syntax error on line 72 of /etc/apache2/plesk.conf.d/server.conf: No matches for the wildcard '*.conf' in '/etc/apache2/plesk.conf.d/ip_default', failing (use IncludeOptional if required)
    Action 'configtest' failed.
    The Apache error log may have more information.

    Aplique la solución detallada en este artículo y proceda con la actualización, si puede iniciar Apache.

  • No se pudo abrir el archivo de configuración /etc/apache2/sites-enabled/000-default: El archivo o directorio no existe

    Apache no puede iniciarse debido al siguiente error:

    apache2: Syntax error on line 268 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/sites-enabled/000-default: No such file or directory

    Elimine el enlace simbólico y proceda con la actualización, si puede iniciar Apache:

    # rm /etc/apache2/sites-enabled/000-default
  • Comando no válido 'LockFile'

    Apache no puede iniciarse debido al siguiente error:

    Invalid command 'LockFile', perhaps misspelled or defined by a module not included in the server configuration Action 'configtest' failed.
    The Apache error log may have more information.

    La directiva 'LockFile' no existe en Apache 2.4. Reemplácela primero por la directiva 'Mutex' en /etc/apache2/apache2.conf :

    LockFile ${APACHE_LOCK_DIR}/accept.lock

    Por lo siguiente:

    Mutex file:${APACHE_LOCK_DIR} default

    Asimismo, reemplace 'SSLMutex' por 'Mutex' en /etc/apache2/mods-enabled/ssl.conf y proceda con la actualización, si puede iniciar Apache.

  • SSLSessionCache: caché de sesión 'shmcb1' no soportada

    Apache no puede iniciarse debido al siguiente error:

    SSLSessionCache: 'shmcb1' session cache not supported (known names: ). 
    Maybe you need to load the appropriate socache module (mod_socache_shmcb?).

    Comente 'SSLSessionCache' en /etc/apache2/mods-enabled/ssl.conf y proceda con la actualización, si puede iniciar Apache.

  • Comando no válido 'Order'

    Apache no puede iniciarse debido al siguiente error:

    Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration.

    Elimine 'Order..' y 'Allow..', añada 'Require all granted' a /etc/apache2/plesk.conf.d/server.conf para todas las secciones tal y como puede ver en el siguiente ejemplo:

    <Directоry "/var/www/vhosts/default/cgi-bin">
    AllowOverride None
    Options None
    - Order allow,deny
    - Allow from all
    + Require all granted
    </Directory>

    Proceda con la actualización si puede iniciar Apache.

  • Apache se inició con ningún sitio

    Apache se inicia correctamente, si bien no se carga ningún sitio.
    La salida de apache2ctl -S solo muestra el sitio predeterminado.

    Cree un enlace simbólico de /etc/apache2/conf.d/zz010_psa_httpd.conf a /etc/apache2/conf-enabled/zz010_psa_httpd.conf

    # ln -s /etc/apache2/conf.d/zz010_psa_httpd.conf /etc/apache2/conf-enabled/zz010_psa_httpd.conf
  • Conflicto de puertos con nginx

    El servidor web Apache no se inicia tras actualizar a Debian 8 y se obtiene el siguiente mensaje de error:

    root@dist-upgrade:~# apache2ctl start
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.

    Esto significa que el archivo /etc/apache2/ports.conf fue sobreescrito por la versión del que mantiene el paquete y que utiliza los puertos 80 y 443 para HTTP y HTTPS, respectivamente. De todos modos, nginx también está en ejecución y utiliza los mismos puertos.

    Para reconfigurar Apache para que utilice los puertos apropiados, desactive y active el servidor proxy inverso nginx:

    # plesk sbin nginxmng --disable
    # plesk sbin nginxmng --enable

    A continuación, ejecute plesk repair web y proceda con dist-upgrade.

Nota : no olvide ejecutar Plesk autoinstaller para instalar todas las actualizaciones disponibles de Plesk tras el dist-upgrade.

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.