Obtención de la advertencia "The following packages cannot be authenticated" cuando se reinstala un paquete aum

Created:

2016-11-16 12:47:35 UTC

Modified:

2017-04-24 12:11:33 UTC

0

Was this article helpful?


Have more questions?

Enviar una solicitud

Obtención de la advertencia "The following packages cannot be authenticated" cuando se reinstala un paquete aum

Síntomas

Cuando se intenta actualizar o reinstalar un paquete aum que tiene activado el repositorio Atomic, se obtiene la siguiente advertencia:

WARNING: The following packages cannot be authenticated!
aum
Install these packages without verification? [y/N]

Causa

En este momento, el repositorio apt de Atomic no está firmado por la clave GPG.

Resolución

  • En el caso de Ubuntu 12/14 y Debian 7, añada '[trusted=yes]' a la descripción de repositorio Atomic en /etc/apt/sources.list :

    deb [trusted=yes]  <repository url>
  • En el caso de versiones anteriores de Debian/Ubuntu, desactive la verificación a nivel global en /etc/apt/apt.conf añadiendo o descomentando esta línea:

    GPG-Check “false”;

Asimismo, intente actualizar la clave GPG:

# wget http://updates.atomicorp.com/channels/tortix-common/RPM-GPG-KEY.atomicorp.txt
# apt-key add RPM-GPG-KEY.atomicorp.txt
¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.