No se puede habilitar el modo PHP en la aplicación FastCGI ni en el módulo Apache para este dominio

Created:

2016-11-16 12:42:36 UTC

Modified:

2017-08-16 17:40:26 UTC

1

Was this article helpful?


Have more questions?

Enviar una solicitud

No se puede habilitar el modo PHP en la aplicación FastCGI ni en el módulo Apache para este dominio

Applicable to:

  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Síntomas

En el menú desplegable de soporte para PHP (en la página Configuración de hosting) no aparecen ni la aplicación FastCGI ni el módulo Apache. Únicamente aparece la aplicación CGI.

¿Qué está causando el problema y cómo puedo resolverlo?

Causa

Plesk opera en modo optimizado para VPS:

# /usr/local/psa/bin/vps_optimized --status
VPS Optimized mysql-innodb: off
VPS Optimized apache-modules-all: on
VPS Optimized apache-modules-except-php: off
VPS Optimized apache-modules-except-scripting: off

En este modo, PHP sólo puede ejecutarse como aplicación CGI

# /usr/local/psa/bin/domain --update example.com -php_handler_type module
WARNING: mod_php is disabled because the Panel operates in the VPS-optimized mode.module is disabled because the Panel operates in the VPS-optimized mode.
SUCCESS: Update of domain 'example.com ' completed.

# /usr/local/psa/bin/domain --update example.com  -php_handler_type fastcgi
WARNING: mod_php is disabled because the Panel operates in the VPS-optimized mode.fastcgi is disabled because the Panel operates in the VPS-optimized mode.
SUCCESS: Update of domain 'example.com ' completed.

Resolución

Vuelva a cambiar el modo de operación de Plesk al modo normal emitiendo la siguiente consulta SQL:

# mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e "update misc set val='0' where param='vps_optimized_mode_status';"

Si desea más información, consulte la guía de administración avanzada de Plesk 11 .

¿Tiene más preguntas? Enviar una solicitud
Inicie sesión para dejar un comentario.