Symptoms
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The following error appears under Plesk > Monitoring after configuring 360 Monitoring:
CONFIG_TEXT: An unexpected error occurred
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The following error is logged in
/var/log/plesk/panel.log
:CONFIG_TEXT: ERR [panel] Unable to Connect to ssl://api.monitoring360.io:443. Error #0: :
0: /usr/local/psa/admin/plib/modules/monitoring/library/Http/HttpClient.php:147
PleskExt\Monitoring\Http\HttpClient->request()
1: /usr/local/psa/admin/plib/modules/monitoring/library/CloudApi/Monitoring360/Monitoring360ApiClient.php:105
PleskExt\Monitoring\CloudApi\Monitoring360\Monitoring360ApiClient->getServerNotifications(string '62...1c')
2: /usr/local/psa/admin/plib/modules/monitoring/library/CloudApi/Monitoring360/Monitoring360ApiBroker.php:161
PleskExt\Monitoring\CloudApi\Monitoring360\Monitoring360ApiBroker->getServerNotifications(string '62...1c')
3: /usr/local/psa/admin/plib/modules/monitoring/scripts/cloud-alerts.php:27
Cause
Outdated CA on the server.
Resolution
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Connect to the server via SSH
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Update certificate authority information:
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Debian-based (Debian/Ubuntu):
# update-ca-certificates
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RHEL-based (RHEL/CentOS/AlmaLinux):
# yum update ca-certificates
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Comments
3 comments
I have this problem after a new SSL certificate was issued for Plesk (I think for the administration interface). Since then the monitoring from the dashboard is not working, however the data is still being sent to the monitoring and the monitoring itself is working. Only the dashboard view does not work, in the log I see Http client exception: Unable to Connect to ssl://api.monitoring360.io:443. Error #0:
The instructions here did not help.
EDIT: Plesk found some bug on their side, they fixed it. If you still have a problem, I recommend contacting support directly. Support responds very quickly, is extremely helpful and solves problems realistically. Quite nice to see well functioning support.
Same here
Plesk > Monitoring shows blank page with "An unexpected error occurred"
= "Nothing to do."
The following error is shown in the Log:
ERR [extension/monitoring] Http client exception: Read timed out after 10 seconds
This Error is mentioned HERE with solution "Can safely be ignored". Well, I'd do so, but as monitoring on monitoring.platform360.io is not working properly either, I think ignoring would not be the right thing to do.
the command doesn't work on my ubuntu server
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