Applicable to:
- Plesk Obsidian for Windows
- Plesk for Windows
Symptoms
-
Plesk panel is not accessible with the following error:
ERROR: Exception: Unable to get PSADb administrator password: The system cannot find the file specified. (Error code 2) on Cannot connect to pipe
-
Plesk Management Service is absent from the Services list in Windows or it cannot be started
Cause
The Plesk Management Service is corrupted or misconfigured
Resolution
-
Connect to the server via RDP
-
Check whether the
plesksrv.exe
is present in%plesk_bin%
directory and apply the appropriate steps:
1. Start the command prompt as the Administrator
2. Run the following commands to reinstall the missing service:
C:\> cd %plesk_bin%
C:\> plesksrv -install
1. Start the command prompt as the Administrator
2. Run the following command to create a temporary directory for extracting the MSI package:
C:\> mkdir C:\pleskmsi
3. Find the Plesk Installer directory - it can be either of these two locations:
CONFIG_TEXT: C:\ProgramData\Plesk\Installer\cache\pool\release\
OR
CONFIG_TEXT: C:\ParallelsInstaller\cache\pool\release\pool\release\
4. Switch to the current Plesk version's directory via CMD. In the example below, path for Plesk Obsidian 18.0.41 is used:
C:\> cd C:\ParallelsInstaller\cache\pool\release\PLESK-WIN_18.0.41_8021\dist-windows
5. Unpack the MSI with the plesksrv.exe
file and copy it to %plesk_bin%
directory:
C:\> msiexec /a plesk-backend.msi /qb TARGETDIR=C:\pleskmsi
C:\> copy "C:\pleskmsi\Program Files\Parallels\Plesk\admin\bin\plesksrv.exe" "%plesk_bin%"
6. Reinstall Install the missing service:
C:\> cd %plesk_bin%
C:\> plesksrv -install
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