Applicable to:
- Plesk for Linux
Symptoms
-
Unable to connect to Plesk server via SSH with
root
user:CONFIG_TEXT: Access denied
Permission denied -
The following error can be found in
/var/log/messages
(e.g. when connected not asroot
):CONFIG_TEXT: hostname crond[30531]: PAM unable to dlopen(/usr/lib64/security/pam_imunify.so): /usr/lib64/security/pam_imunify.so: cannot open shared object file: No such file or directory
-
Plesk notifications may not be sent after the execution of a Daily Maintenance task.
-
Cron tasks are not executed at the required time. In the
/var/log/cron
log file the following errors may persist:CONFIG_TEXT: crond[28816]: (root) PAM ERROR (Module is unknown)
crond[28816]: (root) FAILED to authorize user with PAM (Module is unknown)
Cause
The Imunify360 extension has been recently deleted from the server, however, its leftovers are still present in the /etc/pam.d/system-auth
and /etc/pam.d/password-auth
configuration files.
Resolution
-
Install SSH Terminal extension and login to the server.
-
Comment out corresponding lines in
/etc/pam.d/system-auth
and/etc/pam.d/password-auth
as follows, e.g. using Vi:CONFIG_TEXT: #%PAM-1.0
...
#auth required pam_imunify.so check_only
...
#auth required pam_imunify.so
...
Comments
6 comments
I get this problem and so far I can't login with root
Hello Alan Gonzales,
Please apply the solution from the article and comment out the required lines in the
/etc/pam.d/system-auth
and/etc/pam.d/password-auth
files via the SSH Terminal extension.Hi,
I'm missing an extra step.
vim /etc/ssh/sshd_config
Line:
Match user , comment line.
i did this and it worked
Hello Alan Gonzales,
Thank you for sharing. However, the `Match User` directive is not adjusted during the installation/removal of the Imunify360 extension. The solution described in the article is complete and no additional actions are required in this case.
Hello dear friends.
Following Anastasia's steps the issue has been fixed without adding any further modifications.
My question is to know if we can reinstall the Imunify360 extension and if, by installing it, the same problem will be reproduced again.
Thank you very much in advance.
Alfonso Fernandez
Hello Alfonso Fernandez,
You may install the Imunify360 extension back if required.
This issue only occurs in some cases after the removal of the extension. It will not re-occur with its installation. Normally, these files should be present when Imunify360 is installed.
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