Plesk for Linux
kb: fixed
kb: bug
Applicable to:
- Plesk for Linux
Symptoms
-
After updating Plesk to 18.0.40, it is not possible to log in to Plesk with the following error message:
PLESK_INFO: Lock Manager error:
'getrandom'.
Type Plesk\Lock\Exception
Message Lock Manager error: 'getrandom'.
File Hierarchical.php -
Server is running on Kernel with a version prior to 3.17:
# uname -r
3.10.0
Cause
Product issue:
-
#PPPM-13323 "Certain actions in Plesk on Ubuntu run in an OpenVZ container (for example, migration, Plesk updates, backing up, and so on) no longer fail with the “boost::filesystem::copy_file: Function not implemented” error."
Fixed in:- Plesk Obsidian 08 December 2021 (Linux)
Resolution
Please consider updating your server:
Workaround
If update is not possible for some reason you may try the following
workaround
Update Linux OS kernel and components to the latest version.
PLESK_WARN: Plesk does not provide support when performing Kernel updates on the operating system.
If kernel update is not possible, please contact Plesk Support.
Fix is available in PPS-12126.
Comments
8 comments
Hi,
Thank you for the information. Do you know when 18.0.41 will be released?
Wie kann ich mich an den Service wenden, wenn ich meinen Lizenz Key nicht auslesen kann? Weder Online noch über Kommandozeile?
Hi Les Vikings
This issue has already been addressed in Plesk Obsidian 18.0.40 Update 1.
Same issue here too, yet my Kernel is above that of the mentioned document. soooo... now what !
i'm also getting no updates showing as above.
I'm now locked out of root, which is not a great position to be in.. and i can't login to the plesk CP either.
It may fix the initial error of: Message Lock Manager error: 'getrandom', but less than 60 seconds after clicking update and getting the message: Downloading new installer, you will get "Connection refused" for anything on port 8447. If you leave it for a while, it will do the upgrade to 18.0.40 Update 1, but you will no longer be able to access anything on port 8447 (updates etc). How are we supposed to upgrade to the next release if port 8447 doesn't work?
This issue was resolved for me and multiple other users with the 18.0.41 update https://docs.plesk.com/release-notes/obsidian/change-log/#plesk-18041
that's great, but how can we update if we can't get to the update portal using 8447? i assume via ssh ?
Yes you can SSH in and upgrade via the command line: https://support.plesk.com/hc/en-us/articles/213408749--How-to-upgrade-Plesk-to-the-next-release
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