Symptoms
- I am currently located in India and cannot pay for Plesk license
- My Indian bank credit card does not work for Plesk license purchase
Cause
As of 1 October, the Reserve Bank of India (RBI) mandated changes in the auto debit rule came into effect. This directive is applicable to all recurring payments which were earlier debited automatically from customers' cards (credit/debit/prepaid). This new RBI guideline asks banks and financial institutions to implement an additional factor of authentication for processing online transactions.
Resolution
To pay for a license, please use such payment options as wire transfer or PayPal (without billing agreement. It should be regular PayPal payment with manual confirmation for each charge, not automatic payment).
In case error persists, please contact cleverbridge directly via cs@cleverbridge.com (Cleverbridge is our online store order processing partner and are in charge of all orders at Plesk.com).
There are 2 options to assist the customer:
1) Customer used bank card for payment: Provide customer with the link to change payment details > customer chooses PayPal
2) Customer used PayPal billing agreement: Provide customer with the link to change payment details > change to bank transfer > change to PayPal
If not helpful, provide a trial license to customer if required, address them to contact cleverbridge (cs@cleverbridge.com) or escalate to cleverbridge ourselves.
Comments
2 comments
PayPal (without billing agreement. It should be regular PayPal payment with manual confirmation for each charge, not automatic payment).
Share the screenshot, what is the process?
PayPal payment with manual confirmation ?
The article is useful to identify the problem but actually does not solve the issue. new RBI rules impact recurring payment. However for Plesk, even one time payments do not go through. There is some issue with Plesk payment page. Maybe it still uses older technology.
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