On October 19, 2021, we have enabled single-sign-on for our Plesk Support Center to provide a seamless login/account experience. This implies that you’ll be able to use a single account across any of our web-facing properties.
If you had already registered your account at Plesk 360 (formerly known as My Plesk) please use one for login. Otherwise please re-register it using the same email address as your existing Zendesk login (support account). It’s essential that you use the same email address on our support center to ensure that your tickets stay attached to the same account.

Website on Plesk server suddenly started to show 500 error: AH10292: Invalid proxy UDS filename

Follow

Comments

317 comments

  • Avatar
    Claudio Eterno

    It works to me. Now, I suppose that in the next days you'll solve this problem on apache. For the next upgrade(and correction) do you expect other further manual changes or the next upgrade will be received automatically?

    8
    Comment actions Permalink
  • Avatar
    Vishal Sandwal

    Just came to the Crash Party now! trying the fix!

    1
    Comment actions Permalink
  • Avatar
    Silent Effect AG

    Thank you...

    0
    Comment actions Permalink
  • Avatar
    Markus (Edited )

    Awesome. Saved my morning. Thanks a lot Plesk!

    But how did this happen to me as I have all automatic updates turned off in Plesk? The package should not have been updated ...

    -1
    Comment actions Permalink
  • Avatar
    Leonardo Gandini

    Thanks, woke up in the middle of the night! Saved my day!!

    0
    Comment actions Permalink
  • Avatar
    Abdulla Chozhimadathil

    No LSB modules are available.

    Distributor ID: Ubuntu

    Description: Ubuntu 20.04.3 LTS

    Release: 20.04

    Codename: focal

     

     

    export version="2.4.29-1ubuntu4"; apt-get install apache2=$version apache2-utils=$version apache2-data=$version apache2-bin=$version

    Reading package lists... Done

    Building dependency tree       

    Reading state information... Done

    E: Version '2.4.29-1ubuntu4' for 'apache2' was not found

    E: Version '2.4.29-1ubuntu4' for 'apache2-utils' was not found

    E: Version '2.4.29-1ubuntu4' for 'apache2-data' was not found

    E: Version '2.4.29-1ubuntu4' for 'apache2-bin' was not found

     

    Can anyone help to downgrade in this case ?

    2
    Comment actions Permalink
  • Avatar
    Faith

     

    @:~# export version="2.4.29-1ubuntu4"; apt-get install apache2=$version apache2-utils=$version apache2-data=$version apache2-bin=$version
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/tortix-common.list:1
    W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/tortix-common.list:1
    W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/tortix-common.list:1
    W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/tortix-common.list:1
    W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/tortix-common.list:1
    W: Target CNF (main/cnf/Commands-amd64) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/tortix-common.list:1
    W: Target CNF (main/cnf/Commands-all) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/tortix-common.list:1
    E: Version '2.4.29-1ubuntu4' for 'apache2' was not found
    E: Version '2.4.29-1ubuntu4' for 'apache2-utils' was not found
    E: Version '2.4.29-1ubuntu4' for 'apache2-data' was not found
    E: Version '2.4.29-1ubuntu4' for 'apache2-bin' was not found

    @:~# apt-mark hold apache2
    apache2 set on hold.

    @:~# service apache2 restart

     

     

    nothing changed!!!

    version u18.04

    3
    Comment actions Permalink
  • Avatar
    Vishal Sandwal

    Yes it fixed! Thanks a lot

    0
    Comment actions Permalink
  • Avatar
    netWERKER Mediahaus

    Thx for fast help

    0
    Comment actions Permalink
  • Avatar
    Gunther Hebein

    Thank you, saved my day.

    0
    Comment actions Permalink
  • Avatar
    Alessio Scortichini

    Thx for fast help

    0
    Comment actions Permalink
  • Avatar
    Daniel Egelseer

    Good Morning,

    Thanks for this solution.

    0
    Comment actions Permalink
  • Avatar
    Kernel Labs

    Thanks so much for your quickness

    0
    Comment actions Permalink
  • Avatar
    Kris Lowet

    Abdulla Chozhimadathil check your /etc/apt/sources.list

    That file should include this rule (for 20.04):

    deb http://archive.ubuntu.com/ubuntu focal main restricted
    0
    Comment actions Permalink
  • Avatar
    Paolo Pira

    E: Version '2.4.29-1ubuntu4' for 'apache2' was not found
    E: Version '2.4.29-1ubuntu4' for 'apache2-utils' was not found
    E: Version '2.4.29-1ubuntu4' for 'apache2-data' was not found
    E: Version '2.4.29-1ubuntu4' for 'apache2-bin' was not found

     

    ??? please help

    1
    Comment actions Permalink
  • Avatar
    Harm Jakob Tolsma

    Big thanks for posting the workaround! This saved me a lot of time this morning.

    0
    Comment actions Permalink
  • Avatar
    Bobby Gahan

    THX ... it saves my day... It works

    0
    Comment actions Permalink
  • Avatar
    Oliver Osswald

    Thanks a lot for the downgrade instruction, all my websites are up and running again!

    Now updates for Apache are on hold. Once this is fixed, please instruct on how to release Apache updates again.

    1
    Comment actions Permalink
  • Avatar
    Fabian Rohr (Edited )

    Workaround not working for me either, I'm on Ubuntu 18.04:

    The following packages have unmet dependencies:
    apache2 : Depends: apache2-bin (= 2.4.29-1ubuntu4) but 2.4.29-1ubuntu4.17 is to be installed
    Depends: apache2-utils (= 2.4.29-1ubuntu4)
    Depends: apache2-data (= 2.4.29-1ubuntu4) but 2.4.29-1ubuntu4.17 is to be installed
    E: Unable to correct problems, you have held broken packages.

     

    edit:

    this workaround did it for me:

    sudo add-apt-repository ppa:ondrej/apache2
    sudo apt install apache2
    1
    Comment actions Permalink
  • Avatar
    Nilesh

    thanks - it works fine

    0
    Comment actions Permalink
  • Avatar
    Janis Freimann

    While the solution for Ubuntu 20.04 suggests the version 2.4.41-4ubuntu3, it did not work in my case resulting in:

    # export version="2.4.41-4ubuntu3"; apt-get install apache2=$version apache2-utils=$version apache2-data=$version apache2-bin=$version
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Version '2.4.41-4ubuntu3' for 'apache2' was not found
    E: Version '2.4.41-4ubuntu3' for 'apache2-utils' was not found
    E: Version '2.4.41-4ubuntu3' for 'apache2-data' was not found
    E: Version '2.4.41-4ubuntu3' for 'apache2-bin' was not found

    The solution was to use apt list -a apache2 to list the available versions, and the version eventually was 2.4.29-1ubuntu4.

    1
    Comment actions Permalink
  • Avatar
    Loris Modena

    I solved with update to Apache 2.4.49 

    sudo add-apt-repository ppa:ondrej/apache2
    sudo apt install apache2
    2
    Comment actions Permalink
  • Avatar
    Roeland Lundahl (Edited )

    on Ubuntu 20.04.3 LTS 
    export version="2.4.41-4ubuntu3"; apt-get install apache2=$version apache2-utils=$version apache2-data=$version apache2-bin=$version

    gives me:
    ...
    After this operation, 7168 B disk space will be freed.
    Do you want to continue? [Y/n] Y
    Abort.

    What can I do to find out why it is aborted?
    ---
    update: fixed, just hit enter, instead of typing Y and hot enter

    0
    Comment actions Permalink
  • Avatar
    Manuel Neubecker

    @Roeland Lundahl you can hit RETURN than it will not be aborted (i have had same problem this morning). 

    0
    Comment actions Permalink
  • Avatar
    Blessed Hombarume

    Hi guys, I am failing to implement this, when is this going to be fixed or can I get assistance in having this temporary solution set.

    0
    Comment actions Permalink
  • Avatar
    Mark

    Switching from FPM to FastCGI is the workaround I'm using.

    1
    Comment actions Permalink
  • Avatar
    kelly kolisnik

    yikes - had a lot of websites go down
    thanks for having this fix

    0
    Comment actions Permalink
  • Avatar
    Travis Ecc (Edited )

    Loris Modena this worked for me also.

    Grow If the export command fails on Lightsail (didn't work on mine) try the below.  Fixed mine

    Adding the ondrej/apache2 repo rather than relying on the the Ubuntu releases.

    sudo add-apt-repository ppa:ondrej/apache2
    sudo apt install apache2
    0
    Comment actions Permalink
  • Avatar
    Roeland Lundahl

    Manuel Neubecker Thanks! I just found out, can confirm that works

    0
    Comment actions Permalink
  • Avatar
    Maxie Jazz

    Worked for me, Ubuntu 20.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request