Applicable to:
- Plesk Obsidian for Linux
Symptoms
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Websites show the following error:
CONFIG_TEXT: AH10292: Invalid proxy UDS filename (proxy:unix:///var/www/vhosts/system/example.com/php-fpm.sock|fcgi://127.0.0.1:9000/var/www/vhosts/example.com/httpdocs/public/index.php)
CONFIG_TEXT: Internal Server Error
-
Apache has been updated to a new version recently:
Ubuntu 20.04:
# grep 'status installed' /var/log/dpkg.log | grep apache2:amd64
2021-09-27 12:46:57 status installed apache2:amd64 2.4.41-4ubuntu3.5Ubuntu 18.04:
# grep 'status installed' /var/log/dpkg.log | grep apache2:amd64
2021-09-28 06:25:55 status installed apache2:amd64 2.4.29-1ubuntu4.17
Cause
This is an Apache bug which arose with Ubuntu packages update and later fixed in the following versions:
- Apache for Ubuntu 20 version 2.4.41-4ubuntu3.6.
- Apache for Ubuntu 18 version 2.4.29-1ubuntu4.18.
Plesk uses Apache packages from OS repositories and does not control their version updates.
Resolution
Update Apache packages to fix the issue:
-
Go to Tools & Settings > Server Management > System Updates and click Recheck now.
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Once updates are detected, click Update all.
The issue should be fixed, verify that websites are back online.
-
Connect to the server using SSH.
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Execute below command:
# sudo apt-mark unhold apache2
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Apply steps 2-3 from the resolution.
Comments
319 comments
Thank you so much for providing a fast work-around to this issue!
This bug gives me a heart attack, i thought something bad happens with my servers. Glad it solved with simple step. Thank You
OMG, same here. Woke up sweating. Thanks for the quick fix.
Thanks for the solution.
https://support.plesk.com/hc/en-us/articles/4407366133906
Is the downgrade from 2.49 to 2.41? I have 2.41 and the problem is the same. Error 500 in sites
Domix Domenico Pugliese downgrade is from 2.4.41-4ubuntu3.5 to 2.4.41-4ubuntu3, if you have 2.4.49 you are using likely non-default Ubuntu repository. Make sure you downgrade to "2.4.41-4ubuntu3" specifically, as 2.4.41-4ubuntu3.5 is affected.
I Have installed version 2.4.41
Server Built: 2021-09-23T
can i use your solution? I don't want to make it worse
Thanks
Thanks Very well. The your solution is ok
Help. Export doesn't seem to function on AWS Lightsail Ubuntu 20
Thanks for the workaround. Is there any way updates like this can be validated in a test environment before they are pushed out? I spent a few hours working around this issue before this article was published.
I totally agree - why did this happen in the first place? Just an unfortunate occurrence, or something that could be caught with a better process before being pushed?
hi I'm also facing this issue, how do I do this from the plesk control panel? I have no idea how to implement this and about 8 of my sites are down
Grow You need to run the commands listed in the article from the shell ( i think as root user).
Other work arounds that I found are to turn of the apahce proxying and use nginx (this may be problematic if you have special stuff in your .htaccess files) in Hosting/Apache & nginx Settings , or to change the apache handler in Hosting/Hosting Settings to FAST CGI served by Apache - this will possibly reduce the performance.
You will need to do this for each site. Try one first.
you need to SSH to your server to run those commands, using a terminal
Hey Jason, I'm a noob with CLI but fortunately I can access the terminal through my aws lightsail account. should I just key in the command given above and pray that it works?
Yes this works !
Alternative Solution: Use FastCGI
I have to manually switch to FastCGI instead of FPM for all my domains / subdomains
Any advantages ot FastCGI ?
I tried the 'quick fix' but it didn't work. Nor does switching to FastCGI.
Please provide a working solution.
Can not find version 2.4.29-1ubuntu4 for those packages. I am on Ubuntu 18.04.6
EDIT: My server hoster has its own apt-servers, where the old apache was not available. I had to add the official Ubuntu apt repo. Then I can go with the fix. The following commands are for Germany. Thanks a lot for the fix!
Thanks a lot for this fix!!
Solution worked, thank you! That was a hard awakening this morning ...
Anton Maslov how does one Unhold the updates whenever Plesk released a fix for it? cause of course eventually i would want to update Apache i assume.
is the command for that simply: apt-mark resume apache2 or apt-mark unhold apache2 ?
Thank you for your fast solution. It was not a good way to start the day :-)
What a very nice Morning...
FastCGI help to fix my problem...for now
@Michael Luchich @Jason Koning Plesk installs Apache from official OS Ubuntu repository, once new version of Apache or any other OS related package is available on vendor's side it will be fetched during packages update. As such packages versioning is under control of OS vendor, Plesk could only react and rectify the issue on its occurrence.
No need for morning coffee. Woke up and 20sites down, provided solution worked.
Use uptime monitors ppl good luck.
@LyfeRadio it should be apt-mark unhold apache2
BTW The article will be updated with all the details once the fix is released from Plesk side.
Still trying to figure this s*** out.
ah well, I was going to open a ticket to solve the problem! this solved the problem of sites with errors 500
This article saved my morning. Thank you for the quick workaround, Plesk.
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