Applicable to:
- Plesk for Linux
Symptoms
-
Unable to connect to Google Drive Backup at Plesk > Tools & Settings > Backup Manager > Remote Storage Settings: Upon logging into the Google account and returning to Plesk, instead of showing Google's account details to finish configuring the backup, only a "Cancel" button is shown:
After enabling Debug mode and reproducing the issue, the following can be found in /var/log/plesk/panel.log
CONFIG_TEXT: ERR [panel] Error: Class 'GuzzleHttp\Promise\Utils' not found
file: /usr/local/psa/admin/plib/modules/platform360/vendor/guzzlehttp/promises/src/functions.php
line: 26
code: 0
-
Unable to connect to Amazon S3 Backup at Plesk > Tools & Settings > Backup Manager > Remote Storage Settings. The following error appears in Plesk:
PLESK_ERROR: Internal error
ERROR: Error: Call to undefined method GuzzleHttp\Promise\Coroutine::of() (functions.php:362)[...]
Cause
Plesk Bug #PAUX-3748, which will be fixed in a future update.
Resolution
In the meantime, the following workaround can be applied:
-
Connect to the server via SSH;
-
Copy the PHP class files from
platform360
into the required extension directory. For example:-
To fix Google Drive Backup:
# cp -a /usr/local/psa/admin/plib/modules/platform360/vendor/guzzlehttp/promises/src/*.php /usr/local/psa/admin/plib/modules/google-drive-backup/vendor/guzzlehttp/promises/src/
-
To fix Amazon S3 Backup:
# cp -a /usr/local/psa/admin/plib/modules/platform360/vendor/guzzlehttp/promises/src/*.php /usr/local/psa/admin/plib/modules/s3-backup/vendor/guzzlehttp/promises/src/
On rare occasions, missing file might not be under the
platform360
directory. In this case, search for the file in all extensions and copy it manually:For ie: for
Utils.php
# find /usr/local/psa -name Utils.php | grep modules
Then copy the file for the necessary extension, for example SpamExperts:
# cp -a /usr/local/psa/admin/plib/modules/wp-toolkit/vendor/guzzlehttp/promises/src/Utils.php /usr/local/psa/admin/plib/modules/spamexperts-extension/library/vendor/guzzlehttp/promises/src/
-
-
Go to Tools & Settings > Backup Manager > Remote Storage Settings and configure the desired remote storage extension.
Comments
1 comment
I followed the steps outlined, but the issue persists, I still only get the cancel button.
Could you please help?
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