Does Plesk support Debian 11 OS?

Follow

Comments

16 comments

  • Avatar
    Marco Teelen

    The information is accurate enough, but the fact that almost two months after a planned release of a distribution there's still not even an ETA approaches ridiculous.

    1
    Comment actions Permalink
  • Avatar
    Miguel Monteiro

    Hello Marco Teelen Debian 11 Support will be most likely added in 2022, though we have no exact ETA to share yet.
    Therefore, I recommend reaching out to us by the end of January 2022, as we might have an update on this. 

    -1
    Comment actions Permalink
  • Avatar
    Avi Sellam

    Hi,
    So what do you suggest, for people who did the update automatically?
    I don't want to have to downgrade it to debian 10...
    Do you have an exact ETA to share?

    0
    Comment actions Permalink
  • Avatar
    Kris Lowet

    Hi, any news about Debian 11 support? Thanks.

    0
    Comment actions Permalink
  • Avatar
    Robin Labadie

    Took the team 4 month to support Ubuntu 20 LTS after it's been released. Now we're 6 months after the release of Debian 11, and it still isn't supported by Plesk and not ETA is provided. Differences between Debian 10 and Debian 11 are very minimal, I don't get the reason for such a delay, unless Plesk purposely wants to discourage the use of Debian.

    In the meantime, new supports for distros such as AlmaLinux and RockyLinux that have 0 user base since they are new have been added, before the new version of Debian that was already a supported OS.

    Debian is the mother of all distros, and I find sad to indirectly encourage the use of a mainstream distro such as Ubuntu for server application, when Debian the most standard and reliable distro out there, therefore the best choice for professional applications. Not to mention that Debian and Ubuntu are both given for 5 years lifetime, with options for further support.

    2
    Comment actions Permalink
  • Avatar
    Marco Teelen

    Miguel, you asked me to reach out again at the end of January 2022. It's now well into February 2022.

     

    Is there any news? Even an explanation as to why this is apparently such a difficult task would be helpful.

    0
    Comment actions Permalink
  • Avatar
    Marco Teelen

    A vague "near future" comment followed by an even vaguer "We might have more information about this three months from now" is not even remotely enough, and you managed to miss even that.

     

    0
    Comment actions Permalink
  • Avatar
    Miguel Monteiro

    Hello Marco Teelen and Robin Labadie

    After further review, Debian 11 support is planned to be added in Plesk Obsidian 18.0.42 which has the release date on the first 15 days of March 2022.

    I updated the article accordingly

    0
    Comment actions Permalink
  • Avatar
    Robin Labadie

    Great news @Miguel Monteiro thank you for sharing the information.

    Please, do support Debian early in the future. Remember that people and companies are choosing a distro based on the support you give to them.

    For me, Debian is the most robust distro out there, I would love to see my company's datacenter full of Debian machines rather than fancy "RockyLinux" or else that IMHO adds no benefit to the Linux ecosystem now that CentOS is basically dead.

    1
    Comment actions Permalink
  • Avatar
    Marco Teelen

    Miguel,

    Glad to hear it. Will it be possible to dist-upgrade an existing debian 10 plesk installation without major difficulties, or will this be another situation like debian 9 - debian 10?

    0
    Comment actions Permalink
  • Avatar
    CLICKSPORTS Team

    Is there a way to watch the changelog by email or rss?

    https://docs.plesk.com/release-notes/obsidian/change-log/ 

    1
    Comment actions Permalink
  • Avatar
    Lars Doe

    Plesk Obsidian 18.0.42 has been released on 28th February 2022 and the changelog states that Debian 11 is now supported.

    0
    Comment actions Permalink
  • Avatar
    Mitchell van Bijleveld

    Well, seems like Amavis (Plesk Email Security) won't start correctly.

    ● amavis.service - Interface between MTA and virus scanner/content filters
         Loaded: loaded (/lib/systemd/system/amavis.service; enabled; vendor preset: enabled)
         Active: failed (Result: exit-code) since Mon 2022-04-04 22:06:12 UTC; 5min ago
           Docs: http://www.ijs.si/software/amavisd/#doc
       Main PID: 112369 (code=exited, status=2)
            CPU: 623ms

    Apr 04 22:06:12 37-97-176-119.colo.transip.net systemd[1]: amavis.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
    Apr 04 22:06:12 37-97-176-119.colo.transip.net amavisd-new[112369]: ERROR: MISSING REQUIRED ADDITIONAL MODULES:
    Apr 04 22:06:12 37-97-176-119.colo.transip.net amavisd-new[112369]:   DBD::mysql
    Apr 04 22:06:12 37-97-176-119.colo.transip.net amavisd-new[112369]:   DBD::mysql
    Apr 04 22:06:12 37-97-176-119.colo.transip.net systemd[1]: amavis.service: Failed with result 'exit-code'.
    Apr 04 22:06:12 37-97-176-119.colo.transip.net systemd[1]: amavis.service: Scheduled restart job, restart counter is at 4.
    Apr 04 22:06:12 37-97-176-119.colo.transip.net systemd[1]: Stopped Interface between MTA and virus scanner/content filters.
    Apr 04 22:06:12 37-97-176-119.colo.transip.net systemd[1]: amavis.service: Start request repeated too quickly.
    Apr 04 22:06:12 37-97-176-119.colo.transip.net systemd[1]: amavis.service: Failed with result 'exit-code'.
    Apr 04 22:06:12 37-97-176-119.colo.transip.net systemd[1]: Failed to start Interface between MTA and virus scanner/content filters.

    0
    Comment actions Permalink
  • Avatar
    David Wilson

    How is there no support for Plesk Premium Mail on Debian 11? Debian 11 was released in August of last year, and we're halfway through May. There's little to no documentation specifying that Premium Mail doesn't work on Debian 11 (you have to dig through to find the "supported O/S list").... This makes it very difficult to do server upgrades/replacements and lifecycle planning, when we receive zero communication from Plesk regarding this. Even searching the error "ERR [panel] Extension kolab does not support Debian 11.3:", yields no answers or communication from Plesk surrounding this... which is incredibly bad for a paid extension.

    We are launching new servers with Debian 11, as that allows for significant LTS planning and maintenance. Debian 10 reaches EoL ~ August of this year (not accounting for LTS releases). It just doesn't make sense to launch a new server knowing you'll have to do a dist-upgrade sooner than later.

    1
    Comment actions Permalink
  • Avatar
    Chris Ross

    Debian 11 supported but no chance to install Plesk Premium Mail or Seafile for example.
    Can anyone tell me what the heck i going on?

    0
    Comment actions Permalink
  • Avatar
    Danny Clowes

    Chris Ross

    Debian 11 is supported but other components add-ons are not supported at the moment. Debian 11 only just come out for Plesk not long ago. For this reason, I'm not rushing to upgrade yes yet! Just stay with Debian 10.x.x for this reason. 

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request