Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
Mail user cannot change forwarding settings in Plesk - the text area is greyed out.
-
Javascript errors can be found in the browser console (F12), for example:
-
Firefox
CONFIG_TEXT: Uncaught TypeError: document.getElementById(...) is null
updateRedirectControlsState EmailFormAjax.js:22
a helpers.js:72
_wrapEventTarget trycatch.js:137
h instrument.js:476
_addEvents EmailFormAjax.js:234
render component.js:247
initialize component.js:66
u component.js:55
u form-ajax.js:12
o EmailFormAjax.js:5
default index.js:8
n onReady.js:31
default onReady.js:40
default index.js:7
<anonymous> line 1510 > injectedScript:1489
default require.js:78
async* line 1510 > injectedScript:1488
<anonymous> (index):1510
<anonymous> (index):1510
EmailFormAjax.js:22:115 -
Chrome
CONFIG_TEXT: helpers.js:88 Uncaught TypeError: Cannot read property 'checked' of null
at o.updateRedirectControlsState (EmailFormAjax.js:22)
at HTMLInputElement.a (helpers.js:72)
updateRedirectControlsState @ EmailFormAjax.js:22
a @ helpers.js:72
-
Cause
Product issue:
-
#PPPM-13166 "It is now possible to enable mail forwarding when logged in to Plesk under a mail user account."
Fixed in:- Plesk Obsidian 30 August 2021
Resolution
Workaround
If update is not possible for some reason you may try the following
Until the fix is released we suggest one of the following workarounds:
-
Set up mail forwarding using the Plesk Administrator account.
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Set up mail forwarding using the subscription owner's account.
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Grant the affected user the right to manage mail settings:
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Go to Subscriptions > example.com > Users and select the affected user.
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Create a new user role with the option Create and manage mail accounts and assign it to the affected user or use the existing role with such an option.
Note: the user will be able to manage all mailboxes for that subscription.
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