Unable to update PHP dependencies via PHP Composer in Plesk: Support for composer 1 is deprecated

Follow

Comments

2 comments

  • Avatar
    Peter Debik

    The above command delivers and error that /opt/psa/var/modules/composer/composer.phar is not found.

    The correct command on CentOS 7.9 is:
    /opt/plesk/php/7.4/bin/php /usr/local/psa/var/modules/composer/composer.phar self-update --2

    0
    Comment actions Permalink
  • Avatar
    Vladimir Chernikov

    Hi @Peter Debik,

    Thank you for this information! I will check it and update the article accordingly.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request