Plesk for Linux
kb: technical
Applicable to:
- Plesk for Linux
Symptoms
If you received a ticket bout this issue, notify developers at #fc-task-manager slack channel
-
Unable to create subdomain in Plesk:
Domain sub.example.com creation failed:
Cannot connect to the task manager (plesk-task-manager service might not be running): No such file or directory -
plesk-task-manager
service is not running:# systemctl status plesk-task-manager
● plesk-task-manager.service - Plesk Task Manager Service
Loaded: loaded (/lib/systemd/system/plesk-task-manager.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Cause
Disabled plesk-task-manager
service.
Resolution
-
Connect to the server via SSH.
-
Enable and start
plesk-task-manager
service:# systemctl enable plesk-task-manager && systemctl start plesk-task-manager
Comments
6 comments
I'm still having the issue, I get this when I check for the status
and shows the same error even after trying to enable & start the plesk-task-manager service
What I have tried so far:
- The above solution
- Tried to repair plesk "plesk repair all -y"
- Restart server
Any help would be appreciated, Thanks in advance!
Not Helpful at all.
The service can't be activated at all. Many process can't be finished. A few features that became error after this service suddenly erorr:
1. I can't start Cgroups
2. Cannot scan WordPress with WP-Toolkit
3. Monitoring keep getting error.
4. Subscription monitoring keep dissappearing.
5. I can't start couple of service.
Hello, @Ahmad Khairun
At this point I'd recommend checking the Plesk Task Manager's log file - /var/log/plesk/task-manager.log
During the failure startup attempts a relevant error information should be logged.
Nothing, it's empty
@Ahmad Khairun
Means the article isn't applicable in your case. I'd recommend filing a technical support request then:
https://support.plesk.com/hc/en-us
I solve my problem :
1. Check your plesk-task-manager error with:
In my case, it because of the ownership of the log file is changing (probably deleted by me). It shows:
2. I check for the said file for ownership and permission :
3. Fix the file ownership by setting psaadm:psaadm as the owner and group for the task-manager.log file with the command below:
4. Don't forget to enable and restart the plesk-task-manager service just to be sure:
5. Check your plesk-task-manager, it should be running (I hope):
I hope this help if by anychance you have similar problem.
Please sign in to leave a comment.