Applicable to:
- Plesk Onyx for Linux
Symptoms
-
Unable to update WordPress instance
example.com
using Smart Updates:PLESK_ERROR: Smart Update test run could not be performed due to errors. Address the errors and try running Smart Update again.
Smart Update was unable to correctly clone your website for further analysis. Please try again later.Or
PLESK_WARN: Selected items were updated with errors:
The following errors have occurred while updating WordPress instance #13 ('https://example.com'): - Smart Update was unable to correctly clone your website for further analysis. Please try again later. -
Records like the following can be found in
/var/log/plesk/panel.log
with debugging enabled:CONFIG_TEXT: ERR [extension/wp-toolkit] Failed to generate screenshot for url 'https://example.com/', reason The screenshot service was unable to retrieve page from WordPress website. Please make sure that the website is alive and not hangs.
DEBUG [extension/wp-toolkit] PleskExt\WpToolkit\Exception\Screenshots\ScreenshotsServiceException: The screenshot service was unable to retrieve page from WordPress website. Please make sure that the website is alive and not hangs.CONFIG_TEXT: DEBUG [extension/wp-toolkit] Smart Update could not fetch the website sitemap. The wrong response status code: 404.
DEBUG [extension/wp-toolkit] PleskExt\WpToolkit\SmartUpdates\Exception\SitemapTraverserException: Smart Update could not fetch the website sitemap. The wrong response status code: 404. -
PHP for a WordPress website is set as FPM application served by nginx in Plesk at Domains > example.com > PHP Settings.
-
Permalinks are enabled for WordPress instance
example.com
.
Cause
Permalinks are enabled on the WordPress instance which make the cloned instance unavailable during Smart Updates.
This behaviour is also considered as WordPress Toolkit bug with ID #EXTWPTOOLK-3537 which will be fixed in the future versions of the extension.
Resolution
As a temporary workaround, set another PHP handler:
-
Go to Domains > example.com > PHP Settings.
-
Set PHP handler as run PHP as FPM Application served by Apache.
Comments
10 comments
I got this error message:
"Smart Update was unable to correctly clone your website for further analysis. Please try again later.
MySQL server has gone away"
The website is running only on Nginx with Nginx Caching. Could the reason be the same? Smart Updates works only with Apache?
@Miomir,
Generally error "MySQL server has gone away" looks like something wrong with MySQL server. It might have different reasons behind thought - it might be corrupted database going "down" on attempt to access it or timeout or open files limit and etc.
Please check /var/log/plesk/panel.log for error code as well as mysql.log itself
Still receiving this error:
Tried to changed it to: FstCGI-Application served by Apache.
Hi Noemi van de Moosdijk,
The best in such case would be to open a support request so that this could be investigated.
Sometimes,
the error come from, in domain : web host access > SSH server access > modify default setup ;)
Hello Ange Du Pacifique
Could you let me know the error message you received?
Most probably it has a cause different from this article.
Hi Guys,
I've recently rolled out Smart Update across 30 domains. I'm getting this error with 4 of the domains.
Error:
Website "---" (---): Smart Update could not be completed automatically. Please try running the update manually. Details: Smart Update was unable to correctly clone your website for further analysis. Please try again later.
I'm on Ubuntu 18.04.5 LTS with Plesk Obsidian 18.0.29 Update #2, and all domains on PHP 7.4.9.
Domains in question was initially on "FPM Application served by Apache" when error originally occurred. Have also tried running Smart Update manually after changing to "FastCGI Application served by Apache" and "FPM Application served by nginx". Just gives the same error regardless on this setting. Assuming I do not need to restart for these to take effect.
Any assistance much appreciated.
Web Hosting Access - check/setup IPv6 address, I had "none" after reinstall pages from backup.... this is can be an issue also "Smart Update could not fetch the website sitemap. The wrong response status code: 404"
@JDR,
Make sure your WordPress Toolkit extension version is up to date (Plesk update and WPT update are different terms). If it is already updated, check if symptoms from this article are applicable on your server:
https://support.plesk.com/hc/en-us/articles/360013137720-Smart-Update-fails-unable-to-correctly-clone-your-website-for-further-analysis
Also, you may try temporarily disabling all plugins on a WordPress for affected sites and try smart update feature then (as in some cases similar errors were caused by 3rd-party plugins). If issue remains the same, this is surely not your case.
If issue cannot be solved on your side, consider submitting a support request to Plesk directly or to a reseller, depending on where the license was purchased.
Hello Libor Zeman
Thank you for sharing.
I've tried to reproduce the same behavior with IPv6 being disabled after backup restore but IPv6 remained enabled.
My test server was Plesk 18.0.30, CentOS 7
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