Applicable to:
- Plesk for Linux
Symptoms
- All mail messages migrated from a source cPanel server are shown as corrupted on Webmail(Invalid Address and No subject). The following error is seen on
/var/log/maillog
:CONFIG_TEXT: dovecot Error: service=imap, user=username@example.com, ip=[127.0.0.1]. Mailbox INBOX: UID=33261: read(/var/qmail/mailnames/example.com/username/Maildir/cur/1520269963.M402118P28216V0000000000000802I00000000001840FA.CL0016UC-SG1.WEBVIS.NET,S=1448:2,S) failed: Cached message size larger than expected (1448 > 1188, box=INBOX, UID=33261)
dovecot: Error: service=imap, user=username@example.com, ip=[127.0.0.1]. Corrupted record in index cache file /var/qmail/mailnames/example.com/username/Maildir/dovecot.index.cache: UID 33261: Broken physical size in mailbox INBOX:
Cause
On the source cPanel server, dovecot has compression enabled:
# cat /etc/dovecot/dovecot.conf | grep zlib
zlib_save_level = 6
Plesk migrator transfers messages from cPanel "as-it-is" without any modifications, so the messages are compressed on the source server. after the migration and Plesk is not able to work with them. This Plesk Migrator extension bug with ID #PMT-4651 which plans to be fixed in future extension updates.
Resolution
As a workaround, it's necessary to unpack the mail messages on the target Plesk server manually so it will be able to read the messages properly. This task is supposed to be performed by a system administrator. It's recommended to read through the official dovecot documentation.
There are some available solutions online such as the following, but they are not officially tested and supported.
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