Applicable to:
- Plesk for Windows
Symptoms
-
Unable to access MailEnable webmail via HTTP, the redirect from HTTP to HTTPS fails with the following error message:
CONFIG_TEXT: 500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed. -
Accessing the MailEnable webmail via HTTP locally from the affected Plesk Windows Server provides more details about the error:
CONFIG_TEXT: HTTP Error 500.24 - Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.
Most likely causes:
•system.web/identity@impersonate is set to true.
...
Detailed Error Information:
Module
ConfigurationValidationModule
Notification
BeginRequest
Handler
StaticFile
Error Code
0x80070032
Requested URL
http://webmail.example.com:80/
Physical Path
C:\Program Files (x86)\Plesk\Additional\https-redirect
Logon Method
Not yet determined
Logon User
Not yet determined
Cause
ASP.NET Impersonation is incompatible with the HTTPS redirect.
IIS Manager > Server > IIS > Authentication > ASP.NET Impersonation is Enabled:
Resolution
-
Connect to the server via RDP
-
Go to IIS Manager > Server > IIS > Authentication:
-
Select ASP.NET Impersonation > Click on Disable option located on the right-side Actions menu:
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