Applicable to:
- Plesk for Linux
Symptoms:
-
Nginx is running fine and its configuration is successful:
# nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
-
A similar to the below error message appears on the Home page in Plesk
PLESK_ERROR: New configuration files for the Apache web server were not created due to the errors in configuration templates: nginx: [warn] conflicting server name "example.com" on 203.0.113.2:80, ignored nginx: [emerg] open() "/var/www/vhosts/system/example.com/logs/proxy_access_log" failed (24: Too many open files) nginx: configuration file /etc/nginx/nginx.conf test failed
-
The following command returns a non-empty result:
# plesk db "select description from Configurations where status <> 'ok'\G"
Cause
The issue with web-server configuration has been previously fixed, but the Plesk database still contains old error messages.
Resolution
- Connect to the server via SSH.
-
Create folder for temporary used files:
# mkdir -p /tmp/plesksupport
-
Create file with other affected domains:
# MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -uadmin psa -Ne"select name from domains where id in (select objectId from Configurations where status<>'ok')" > /tmp/plesksupport/domainlist.txt
-
Reconfigure other affected domains:
# cat /tmp/plesksupport/domainlist.txt | while read domain; do /usr/local/psa/admin/bin/httpdmng --reconfigure-domain $domain; echo "$domain - success"; done
# /usr/local/psa/admin/bin/httpdmng --reconfigure-server
Comments
3 comments
The problem persists for me. Error message after usign this "fix":
File Path: n/a
is shown as eeronous. All other files are green.
Fun fact: Ihad that ipv6 address active. As of now all sites are disconnected from the IP. So it shouldnt be relevant at all for plesk or apache/nginx. Yet it is correctly assigned to the server.
Hello Martin Sauer
Plesk, check the Nginx configuration:
# nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
If you have the same output as provided, Nginx configuration is fine and this error message is orphaned and to remove it you may use this instruction: https://support.plesk.com/hc/en-us/articles/213389789
Otherwise, the output will provide a hint of where to check the issue.
In case of getting stuck, submit a support request to support Plesk directly or to the partner where the license was purchased.
Ivan Postnikov Thank you so much. You nailed it. There were some other support entries with similar solutions, but apparently my OS configuration wasnt ok by then. Now it was and all problems solved.
Thank you again - good one.
Please sign in to leave a comment.