Symptoms
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Unable to remove Wordpress instances via Domains > example.com > Applications > Remove:
Permission Denied
Page just reloads with no errors
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In some cases, the process finishes with the message below, but the WordPress instance is still shown:
{"status":"success"}
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The following error can be observed with debug enabled in
%plesk_dir%admin\logs\php_error.log
:2019-06-19 21:45:55] ERR [extension/wp-toolkit] An error occurred when dispatching action 'removeAction': Permission denied
[2019-06-19 21:45:55] DEBUG [extension/wp-toolkit] pm_Exception: Permission denied
file: C:\Program Files (x86)\Parallels\Plesk\admin\plib\modules\wp-toolkit\library\Controller\Action.php -
Attempts to remove the instance return
{"status":"success"}
on a blank page in a browser
Cause
This issue is reported as bug ID EXTWPTOOLK-3043 which will be fixed in future updates.
Resolution
Until the issue is resolved, the following workaround can be applied:
- Log into Plesk.
- Remove instance via Wordpress Toolkit
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Connect to the server via SSH
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Run the following command to find the ID of the instance:
# plesk ext wp-toolkit --list |grep example.com |awk {'print $1"\t"$7'}
365 http://example.com/old -
Remove the instance with the following command. Use the ID from step 2. as value after
-instance-id
:# plesk ext wp-toolkit --detach -instance-id 365
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Remove the WordPress related files of the removed instance in the file system
In case instance files are already removed from disk and the Toolkit does not detect them:
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Scan for instances in Wordpress Toolkit on Subscription level and identify the instances IDs from the warning: Scanning for WordPress websites was performed with errors:
Subscription "example.com": Failed to reset cache for the instance #265: Error: This does not seem to be a WordPress installation. Pass --path=`path/to/wordpress` or run `wp core download`. Failed to reset cache for the instance #273: filemng: Failed to change directory to /var/www/vhosts/example.com/httpdocs/wordpress: No such file or directory System error 2: No such file or directory filemng: Failed to change directory to /var/www/vhosts/example.com/httpdocs/wordpress: No such file or directory System error 2: No such file or directory
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Manually remove instances data from Wordpress Toolkit database:
# cp /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3.bak
# sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3
sqlite> .headers on
sqlite> delete from instanceProperties where instanceId = 265;
sqlite> delete from instances where instances.id = 265;
sqlite> delete from instanceProperties where instanceId = 273;
sqlite> delete from instances where instances.id = 273;
sqlite> .quit -
Remove the instances via subscription Applications tab
Comments
5 comments
I am on Plesk ObsidianVersion 18.0.31. I tried install wordpress using Wordpress Toolkit but the installing wordpress was stuck. I followed this page (https://support.plesk.com/hc/en-us/articles/360013425599-WordPress-Toolkit-stuck-at-0-when-installing-a-new-instance). Now I Unable to remove Wordpress instances via Domains > example.com > Applications > Remove. It keep showing there. Any help appreciated.
How can this be the official resolution?
Removing an Wordpress-Instance with the "Wordpress Toolkit" is not possible with the "Plesk Web Admin" version.
What if the instance is not under WordPress Toolkit and it was already deleted via SSH (so I cannot just Scan again with WP Toolkit?)
Hello Marcel van der Heide and Marco Marsala,
We updated the article with steps to remove such instances without them being removable using WordPress Toolkit GUI.
Provided commands:
won't always work because the column "Website URL" may be blank in output of first command. Please note the ID is shown in the redirected page URL after clicking Remove.
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