CentOS 8/RHEL 8 support in Plesk

Follow

Comments

9 comments

  • Avatar
    Mitchell van Bijleveld

    Is Docker supposed to be supported later or is this never going to work and only remotely?

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Mitchell van Bijleveld

    Yes, it's going to be available. Work on it is currently in progress.

    2
    Comment actions Permalink
  • Avatar
    Peter

    Do we know of a time frame for when Advanced ModSecurity Rules by Atomicorp, will be available for usage? A rough estimate.

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Hi Peter, the ball is on Atomicorp side. As soon as they add support for RHEL/CENTOS 8 we will be able to use it in Plesk. To clarify ETA you may want to reach them here. Meanwhile I do recommend to use Comodo. 

    0
    Comment actions Permalink
  • Avatar
    Dennis Am

    Docker now works on CentOS 8 (since Docker extension version 1.4.6): https://docs.plesk.com/release-notes/obsidian/change-log/#docker-1.4.6

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Hi Dennis, updated article by removing Docker from known issues, thank you noticing!

    0
    Comment actions Permalink
  • Avatar
    Mitchell van Bijleveld

    Only the remote docker functionality. Docker managing on the server is still not available.

    0
    Comment actions Permalink
  • Avatar
    Peter

    The extension seems to work, i cannot however add the Docker server. 

    0
    Comment actions Permalink
  • Avatar
    GK (Edited )

    Hi,

    Thanks for the good work. I know the big difference between EL7 and EL8 (for example the dnf modules). We always used the official MariaDB (not the redhat ones) packages for the DB on EL7. On EL8 this doesn't work anymore:

    Problem 1: package plesk-backup-utilities-18.0-2.centos.8+p18.0.25.2+t200325.1928.x86_64 requires plesk-mysql-server >= 18.0, but none of the providers can be installed
    - package plesk-mysql-server-18.0-2.centos.8+p18.0.24.0+t200128.1353.noarch requires mariadb-server >= 5.0.60, but none of the providers can be installed
    - conflicting requests
    - package mariadb-server-3:10.3.17-1.module+el8.1.0+3974+90eded84.x86_64 is excluded

    I understand the message because we had to disable the mariadb module because we wanted to use the MariaDB packages.  Right now:

    MariaDB-common-10.3.22-1.el8.x86_64
    MariaDB-server-10.3.22-1.el8.x86_64
    MariaDB-client-10.3.22-1.el8.x86_64

    Fix:

    Adding the official MariaDB packages to the required list in the RPM is very easy (did it myselves a couple of times). Check https://rpm.org/user_doc/boolean_dependencies.html . With this trick you can have a dependency on mariadb-server AND MariaDB-server.

     

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request