kb: bug
ABT: Group B
Applicable to:
- Plesk for Linux
If you reuse this article in your ticket, ask the customer why it is important for them to use additional admin account for API instead of built-in admin user. Forward the customer's response to @btsydenov
Symptoms
Unable to run an API request using an additional Plesk administrator account, the following error is shown:
"message": "Can not find client by login 'johndoe'"
Cause
Plesk bug #EXTREST-87: API requests cannot be executed under additional Plesk administrator accounts.
Resolution
Until a fix will be available, execute the API request using built-in "admin" account instead, for example:
# curl -k -u admin:password -X POST -d @domain.json "https://203.0.113.2:8443/api/v2/domains"
Comments
5 comments
Hello Plesk,
Is there already a update regarding this issue?
Hello Plesk,
Do you have an update that resolves this issue?
Hello,
we are also waiting eager for this Bug to be fixed. Any ETA on this as Customers of our Plesk Servers are waiting for this ...
Hello Daniel Broen, Ralph Otowo and Andreas Schnederle-Wagner
Could you please describe your use-cases? Why do you need to use additional Plesk administrator accounts for API instead of built-in 'admin' user?
In addition, there are different authentication methods in REST API, one of them is API keys - https://docs.plesk.com/en-US/obsidian/api-rpc/about-rest-api.79359/#authentication-methods. Does it anyhow help you in your scenarios?
Bulat Tsydenov - haven't seen your reply earlier.
Our Use-Case - we are Service Provider, on the Plesk Servers for our Customers we keep the "Main Admin" Account with "our Password" and Customer get additional Plesk Admin Account.
Some of our Customers are using the API ... there is the Problem ... they can't use the API with their Admin User ...
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