Plesk for Windows
Plesk for Linux
kb: bug
ABT: Group A
Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
The domain is suspended with non-existing status code (What do the domain status codes in Plesk mean)
-
The domain cannot be unsuspended using API.
Request:CONFIG_TEXT: <packet>
<site>
<set>
<filter>
<name>
example.com
</name>
</filter>
<values>
<gen_setup>
<status>
0
</status>
</gen_setup>
</values>
</set>
</site>
</packet>Response:
CONFIG_TEXT: <status>error</status>
<errcode>1025</errcode>
<errtext>The domain is still suspended for the following reason: Domain is inactive.</errtext>
Cause
Plesk bug #PPPM-10528, which is planned to be fixed in future product updates.
Resolution
Set any other non-zero status code. For example:
- Switching between valid status codes works: "0 => 2 => 0".
- Switching from invalid status code to "0" fails: "0 => 8 => 0" (error).
- But switching from invalid status code to a valid one and then to "0" works: "0 => 8 => 2 => 0".
Comments
4 comments
has bug #PPPM-10528 been fixed in a release yet?
Hello @Joe,
According to the information I have this bug is yet to be fixed.
As soon as there'll be any news or ETA, this article will be updated.
Hi Ivan, are you able to provide an ETA on when the bug fix will be released? We are the customer of this product and our business owner is not willing to approve the product going into Production without definitive date. Are we talking about approx. 1 to 3 months away?
Hello @swang liao,
As soon as the ETA or more precise information will appear, this article will be updated. Click "Follow" to be notified about the article updates.
This particular issue appears if domain was suspended with non-existing status code.
To avoid this issue it is sufficient to make sure that correct status is used when suspending a domain using API.
The list of correct statuses may be found here: https://support.plesk.com/hc/en-us/articles/213902805
Please sign in to leave a comment.