Applicable to:
- Plesk for Linux
Symptoms
-
One of the following error messages is shown in Plesk GUI when a backup upload has failed to be uploaded to OneDrive remote storage:
PLESK_ERROR: Unable to upload the archive domains/example.com/backup_statistics_1904241438.tgz to the external storage: Transport error: Extension transport: ext://one-drive-backup/server/: Server error: POST https://graph.microsoft.com/v1.0%2Fme%2Fdrive%2Fspecial%2Fapproot/children resulted in a 504 Gateway Timeout response: { "error": { "code": "UnknownError", "message": "", "innerError": { "request-id": "0e41054e-cdd (truncated...)
OR
PLESK_ERROR: Error: hosting "example.com"
Unable to upload the archive domains/example.com/backup_conf_1906251346.tgz to the external storage: Transport error: Extension transport: ext://one-drive-backup/server/: Server error: `POST https://graph.microsoft.com/v1.0%2Fme%2Fdrive%2Fspecial%2Fapproot/children` resulted in a `503 Service Unavailable` response: { "error": { "code": "serviceNotAvailable", "message": "Service unavailable", "innerError": { " (truncated...)OR
PLESK_ERROR: Unable to upload the archive clients/clt02/domains/example.com/backup_user-data_1909301059.tgz to the external storage: Transport error: Extension transport: ext://one-drive-backup/server/: Server error: GET https://john-doe.sharepoint.com/personal/tobias_gross_tgross_ch/_api/v2.0/drive/items/017ECJJAQTTTJLEY3Y35GZFXAVVC2JK2G3/uploadSession?guid='1bfbdd0e-5cb4-4c78-bd15-[ID] resulted in a 503 Service Unavailable response:
-
Sometimes, Backups stored in remote OneDrive storage fails with the following error message:
PLESK_WARN: Warning: Could not display the list of backups in the Microsoft OneDrive Backup storage: Unable to get dumps list: Transport error: Extension transport: ext://one-drive-backup/server: Server error: `GET https://graph.microsoft.com/v1.0%2Fme%2Fdrive%2Fspecial%2Fapproot/children?select=name,size,folder,file` resulted in a `503 Service Unavailable` response: { "error": { "code": "serviceNotAvailable", "message": "Service unavailable", "innerError": { " (truncated...) . Please check the storage settings.
-
Sometimes, trying again to perform the backup finishes successfully.
-
Performing a OneDrive API call manually to list the backups sometimes fails with the same error message:
# /usr/local/psa/admin/bin/backup_restore_helper --extension-transport ext://one-drive-backup/server/ -operation list -path ''
Server error: `GET https://graph.microsoft.com/v1.0%2Fme%2Fdrive%2Fspecial%2Fapproot/children?select=name,size,folder,file` resulted in a `503 Service Unavailable` response:
{
"error": {
"code": "serviceNotAvailable",
"message": "Service unavailable",
"innerError": {
" (truncated...)
Cause
This is a OneDrive Backup bug with ID EXTPLESK-1340, that will be fixed in future product updates.
Resolution
- Wait for a few minutes and re-try to create the backup.
- Contact Microsoft Support for a permanent solution.
Comments
0 comments
Please sign in to leave a comment.