A domain secured with a Let's Encrypt certificate is marked as not secured in Plesk Advisor: The certificate is either self-signed or not vaild

Follow

Comments

6 comments

  • Avatar
    Chris Mallabon

    This just reappeared in the last few days. It's also saying that Plesk is not secured but it also is.

    0
    Comment actions Permalink
  • Avatar
    Yulia Plokhotnikova

    Hello @Chris Mallabon,

    Could you try to apply the workaround, is it help to fix the issue? what Plesk version is currently installed?

    0
    Comment actions Permalink
  • Avatar
    Chris Mallabon

    Workaround didn't work. Note: got a certificate error trying to download PEM file so had to turn off verification. Was on Version 18.0.38 Update #2 but got Update #3 a few days ago and still have the issue. 

    0
    Comment actions Permalink
  • Avatar
    Chris Mallabon

    Oh, the issue appeared when either Update #2 or possibly the one before that was installed. 

    0
    Comment actions Permalink
  • Avatar
    Yulia Plokhotnikova

    @Chris Mallabon, so when Plesk was updated to #3, issue is fixed, correct? If not, please send all the symptoms that are currently actual.

    0
    Comment actions Permalink
  • Avatar
    Chris Mallabon

    No it wasn't fixed. All domains are secured with Let's Encrypt but Advisor has them all flagged as red (The certificate is either self-signed or not valid) under Certificate with the error "13 of 13 (100%) websites are not secured with valid SSL/TLS certificates". It also says "Plesk is not secured". I have manually renewed the Plesk certificate and several domains to see if that would fix it, but it didn't change. When I log into Plesk or go to any of the domains, there aren't any SSL warnings so certs appear to be fine.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request