"apt update" is not working on Plesk server with Ubuntu or Debian after installing PageSpeed Apache module using Google PageSpeed Insights extension: The repository 'http://dl.google.com/linux/mod-pagespeed/deb/dists/stable/Release.gpg' is not signed

Follow

Comments

4 comments

  • Avatar
    Morgan C Smith

    When you say current directory do you mean the home directory? 

  • Avatar
    Alexey Lapshin

    @Morgan

    In step 2 under "current directory" mentioned your current working directory.

    It is displaying as an output of the following command execution:

    # pwd
  • Avatar
    Marcelo Sanchez

    Hello, I still have that problem,
    Installation will not continue

    The apg-get failed with the following message:
    Reading package lists ...
    Building dependency tree ...
    Reading state information ...

    The LOG file says this

    Execution failed.
    Command: autoinstaller
    Arguments: Array
    (
        [0] => --select-product-id
        [1] => plesk
        [2] => --select-release-current
        [3] => --upgrade-installed-components
    )
    
    ...
    W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com/linux/mod-pagespeed/deb stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E
    W: Failed to fetch http://dl.google.com/linux/mod-pagespeed/deb/dists/stable/Release.gpg  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6494C6D6997C215E
    W: Some index files failed to download. They have been ignored, or old ones used instead.
    Retrieving information about the installed license key...
    Launching component and product checkers...
    ..
    ---X--- `apt-get` output ---------------------
    Reading package lists...
    Building dependency tree...
    Reading state information...
    
    ---------------------- `apt-get` output ---X---
    Collecting error details into the log file...
    
    ERROR: Installation will not continue
    
    The apg-get failed with the following message:
    Reading package lists...
    Building dependency tree...
    Reading state information...
    
    Not all packages were installed.
    Please contact product technical support.

    How can I solve it?
    Thank you

  • Avatar
    Anzhelika Khapaknysh

    @Marcelo Sanchez,

    Could you please check the version of Google PageSpeed Insights extension in Plesk > Extensions > My Extension tab?

Please sign in to leave a comment.

Have more questions? Submit a request