Applicable to:
- Plesk Obsidian for Linux
- Plesk Onyx 17.5 for Linux
Symptoms
- destination@example.com is set up as forwarding destination mail address in Domains > example.com > Email Addresses > source@example.com;
- source@example.com has reached its mailbox size limit;
- Mailbox for mail address source@example.com was turned off in Domains > example.com > Email Addresses > source@example.com;
- After that mail is not delivered to the destination@example.com with the following error in
/var/log/maillog
:CONFIG_TEXT: Mar 13 13:01:09 ppu17-5 postfix/smtpd[6797]: connect from localhost[::1]
Mar 13 13:01:09 ppu17-5 postfix/smtpd[6797]: 7842561C3AA3: client=localhost[::1], sasl_method=DIGEST-MD5, sasl_username=sender@example.com
Mar 13 13:01:09 ppu17-5 postfix/cleanup[6801]: 7842561C3AA3: message-id=<47661669ceb88b53fa04f23356a1330f@example.com>
Mar 13 13:01:09 ppu17-5 check-quota[6803]: Starting the check-quota filter...
Mar 13 13:01:09 ppu17-5 /usr/lib64/plesk-9.0/psa-pc-remote[15087]: handlers_stderr: DATA REPLY:452:4.2.2 Mailbox full#012DEFER
Mar 13 13:01:09 ppu17-5 /usr/lib64/plesk-9.0/psa-pc-remote[15087]: DEFER during call 'check-quota' handler
Mar 13 13:01:09 ppu17-5 postfix/cleanup[6801]: 7842561C3AA3: milter-reject: END-OF-MESSAGE from localhost[::1]: 4.2.2 Mailbox full; from=<sender@example.com> to=<source@example.com> proto=ESMTP helo=<webmail.example.com> -
The same error appears in logs if destination@example.com is disabled but its folder remains on the file system at
/var/qmail/mailnames/example.com/destination/
and its size reached the mailbox limit set previously in Domains > example.com > Email Addresses > destination@example.com:# du -sh /var/qmail/mailnames/example.com/destination/
105M /var/qmail/mailnames/example.com/destination/
Cause
The issue is caused by bug with ID #PPPM-10245, which is planned to be fixed in product future updates.
Resolution
As workaround,
- Log into Plesk
- Switch Mailbox back on for the email source@example.com (or for destination@example.com depends on whichever is limited) in Domains > eample.com > Email Addresses.
Note: After re-enabling the mailbox, either free space or increase the mailbox limit
Comments
4 comments
This is a major major MAJOR issue on all our servers. Client email boxes that are OFF keep filling up and they suddenly stop receiving emails. We need a fix for this ASAP! We need a workaround that auto-clears messages from the mailboxes when they're off. A mailbox that is OFF should NOT STORE EMAILS. This is only a problem with the latest Plesk version and we have tons of accounts that use forwarding - we can't go in every few days and clear these out one by one on each system. Please fix or give us a real workaround like a cron job!
Plesk pointed me to this article to use to purge messages until this bug is fixed.
https://support.plesk.com/hc/en-us/articles/115002372774-How-to-delete-all-or-some-emails-from-a-mailbox-without-logging-in-to-the-mailbox-
There is an ETA for fixing this Bug ?? Honestly we are losing clients due this issue, and we are wondering if exists a solutions or not.
We have start to test another email server software alternatives, because of multiple incidents originated by this bug.
Hello Manuel Munoz,
As far as I see, you have already contacted Plesk Technical support regarding this inquiry and the question is under the clarification right now.
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