Applicable to:
- Plesk Obsidian for Linux
Symptoms
-
Plesk was upgraded to the Obsidian 18.0.33 version.
-
In an attempt to create a backup to remote FTP storage or add the remote FTP backup storage in Plesk > Tools & Settings > Backup Manager > Remote Storage Settings, the process fails with the error below:
PLESK_ERROR: Transport error: unable to list directory: Curl error: (7) Couldn't connect to server: Last FTP request: PASV Last FTP response: 227 Entering Passive Mode
Make sure you have entered the correct storage settings. You can check them independently with the command: curl -v -P - -u jdoe 'ftp://203.0.113.2/' -
The manual connection to the remote FTP backup storage from the server-side fails after switching from
EPSV
toPASV
mode:# curl -v -P - -u johndoe 'ftp://203.0.113.2/'
> EPSV
* Connect data stream passively
* ftp_perform ends with SECONDARY: 0
< 502 command not implemented
* Failed EPSV attempt. Disabling EPSV
> PASV
Cause
Product issue:
- #PPPM-12699 "It is now again possible to create backups stored in FTP storage. This feature was broken since Plesk 18.0.33."
Fixed in:- Plesk Obsidian 09 March 2021
Resolution
- Upgrade Plesk to 18.0.34 version.
- Log into Plesk.
- Go to Extensions > My Extensions > Panel.ini Editor > Open > Editor.
Note: in case the Panel.ini Editor extension is missing, install it using this article.
- Add the line below under the
[pmm]
section:
ftpAllowPassiveIpChange = 1
- Scroll down and press the Save button.
Note: apply the workaround below only if the remote FTP storage supports active mode.
- Log into Plesk.
- Go to Tools & Settings > Backup Manager > Remote Storage Settings.
- Uncheck the Use passive mode option and press the OK button to apply the changes:
Comments
7 comments
I've upgraded to 18.0.34 and the error is still there. I tried the workaround 1 and it didn't work. I can't use the workaround 2 since the ftp server doesn't have active mode and is controlled by my hosting company.
Can you help? Thanks
I also upgraded to 18.0.34 and cant connect to FTP, Workaround 1 is not working for me.
The problem persist.
Hello FGP,
Please submit the request to Plesk support that we can check such a case directly.
Here is how: https://support.plesk.com/hc/en-us/articles/213608509
I finally found what was the problem. I had a '@' on my password. It's a problem of libcurl, because other plesk installation all works as expected.
The solution is now working, thanks
Hi there FGP,
Thanks for sharing your solution with us!
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