Plesk for Linux
kb: fixed
kb: bug
Applicable to:
- Plesk for Linux
Symptoms
-
SpamAssassin update fails:
CONFIG_TEXT: channel: no 'mirrors.sought.rules.yerp.org' record found, channel failed
channel: no 'mirrors.updates.spamassassin.org' record found, channel failed
Update available, but download or extract failed -
Plesk Administrator receives notifications containing the same error message.
Cause
Product issue:
-
#PPPM-12848 "In Plesk Obsidian 18.0.34 and later, updating SpamAssassin rules no longer fails with the “channel: no ‘mirrors.sought.rules.yerp.org’ record found” error."
Fixed in:- Plesk Obsidian 25 March 2021 (Linux)
- Plesk Obsidian 23 March 2021 (Linux)
Resolution
Please consider updating your server:
Workaround
If update is not possible for some reason you may try the following
workaround
Until the issue is fixed, disable the repository manually as a workaround:
Comments
13 comments
commenting
return 0
will result in these errors:
/etc/mail/spamassassin/channel.d/sought.conf: line 7: -----BEGIN: command not found
/etc/mail/spamassassin/channel.d/sought.conf: line 8: syntax error near unexpected token `('
/etc/mail/spamassassin/channel.d/sought.conf: line 8: `Version: GnuPG v1.4.1 (GNU/Linux)'
Same errors as Marco after commenting out
#CHANNELURL=sought.rules.yerp.org
#KEYID=6C6191E3
#return 0
/etc/mail/spamassassin/channel.d/sought.conf: line 7: -----BEGIN: command not found
/etc/mail/spamassassin/channel.d/sought.conf: line 8: syntax error near unexpected token `('
/etc/mail/spamassassin/channel.d/sought.conf: line 8: `Version: GnuPG v1.4.1 (GNU/Linux)'
Indeed this is not fixed, still getting cron update with this message, like Marco first posted:
/etc/mail/spamassassin/channel.d/sought.conf: line 7: -----BEGIN: command not found
/etc/mail/spamassassin/channel.d/sought.conf: line 8: syntax error near unexpected token `('
/etc/mail/spamassassin/channel.d/sought.conf: line 8: `Version: GnuPG v1.4.1 (GNU/Linux)'
doing
sa-update -v
Update available for channel updates.spamassassin.org: 1887567 -> 1887624
http: (curl) GET http://spamassassin.apache.org/updates/MIRRORED.BY, success
http: (curl) GET http://www.sa-update.pccc.com/1887624.tar.gz, success
http: (curl) GET http://www.sa-update.pccc.com/1887624.tar.gz.sha512, success
http: (curl) GET http://www.sa-update.pccc.com/1887624.tar.gz.asc, success
Update was available, and was downloaded and installed successfully
Thanks for your comments, the article has been modified accordingly.
Hello,
Maybe I'm missing something? But I don't see any changes in the article...
I did the commenting of the files on my servers (yesterday) but received the same emails this morning.
@Spinnerz
The 'return 0' line should not be commented out. The 1st and the 4th lines are usually already commented out. If the issue still persists, you can submit a ticket to Plesk Support.
@Leonid Gukhman
Thank you for your update!
It seems this article is missing this after the edit to actually activate it.
Updated to Plesk Obsidian 18.0.34 Update #2, but this issue persists
spamfaenger
Restarting SpamAssassin is not required after changing channels config.
Jeffrey Kastner
The issue should have been fixed by the update. If it persists, consider contacting Plesk Technical Support for further investigation.
Leonid Gukhman, unfortunately "the Plesk license was purchased not directly from Plesk but through one of the Plesk Resellers"... so I am reporting the issue here,, as it seams it IS a Plesk issue.
Jeffrey Kastner
You can contact the company you purchased the license from. Plesk Partners (Resellers) are fully trained by Plesk and can assist you with it as well.
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