Plesk for Linux
kb: bug
ABT: Group A
Applicable to:
- Plesk for Linux
Symptoms
- Forwarded messages from some domains are not delivered.
- The following messages can be found in
/var/log/maillog
:CONFIG_TEXT: postfix-srs: [srs0=lyd5=qz=example.com=bounces 337318-83a0-test=example.com@example.com] not rewritten: Hash invalid in SRS address.
- The original rewriteable line contains the "+" symbol:
CONFIG_TEXT: [SRS0=LYD5=QZ=example.com=bounces+337318-83a0-test=example.com@example.com]
Cause
Product issue:
-
#PPPM-10128 "Postfix Sender Rewriting Scheme (SRS) now works with email addresses that contain the plus sign (+)."
Fixed in:- Plesk Obsidian 23 June 2020 (Linux)
Resolution
Please consider updating your server:
Workaround
If update is not possible for some reason you may try the following
workaround
As a workaround, disable SRS as described in the following article:
Comments
8 comments
Hi,
Any ETA on a fix or possibly a valid workaround? The suggested workaround is not really an option as it breaks when SPF is used on the sender domain. This was not an issue with Plesk Onyx 17.5 with the suggested workaround to install postsrsd and a custom plesk-pc-mail-driver.
Regards,
Michel
Hello Michel,
I totally understand your concern.
The issue #PPPM-10128 is quite rare, thus our development team decided to postpone the fix for the time being.
I appreciate your understanding.
Hi Alexey,
Thanks for your response. I don't mean to sound annoying, but in the past 14 hours this error is logged in the maillog 48 times. I wouldn't call this a rare issue. This is on a system with approx. 200 active subscriptions. Are we facing something different here? This is on a CentOS 7 system with Plesk Onyx 17.8.11 Update #72 installed. I think it highly depends on from what sources you receive e-mail a lot.
I would appreciate it if this issue is given more attention.
Kind regards,
Michel
Hello @Michel,
The issue is confirmed as important due to its impact. However, the ETA, for now, is unavailable.
To make sure the issue doesn't have another cause in your cause, you may submit a request to Plesk Support directly to Plesk or to one of our partners, depending on where the license was purchased.
Hi, same Problem here. It would be nice to have a bugfix shortly. I spent weeks (and money for service providers) to investigate why there are problems with srs. So i would say this is an important issue.
Hello @TS,
Thank you for bringing our attention to this.
The issue has been already prioritized, however, the exact ETA is not available.
Hi,
I would like to stress here that the proposed resolution is not a solution. It is hardly even a workaround, because turning off SRS breaks with domains configured with an SPF record. As it is impossible to control this for all the domains on the internet, this renders forwards with SRS enabled AND SRS disabled useless.
Please fix this issue ASAP.
Regards,
Michel
@Michel Otte Got your point, but we do not have ETA for the bug yet.
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