If custom value is set for SPF explanation text, it is ignored in SPF-Check

Follow

Comments

9 comments

  • Avatar
    Arjan Groenemeijer (Edited )

    Could you please release a quick fix? The plan "to be fixed in one of the future updates" sounds like underrating the importance of 
    proper SPF filter handling, which is nowadays a vital asset in even the most modest hosting service level that involves mail.

    It seems that a custom notification in combination with a reject mode, ignores any SPF check completely.
    With this combo all mail that should have been rejected is accepted instead and  missing any spf related headers..
    Without the custom SPF explanation text the SPF reject on fail works, but with the above mentioned 550 5.7.1 status.
    (CentOS Linux 7.4.1708 / Plesk 17.8.11 Update #49)

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello @Arjan,

    Thank you for the feedback.

    The issue was already fixed for the future major release. It should be already available in Plesk 17.9 preview version (not for production usage).

    The backport to Plesk 17.8 is also planned. However, there is no exact ETA for now, stay tuned for this article updates.

    0
    Comment actions Permalink
  • Avatar
    Robin Labadie (Edited )

    Hello,

    We (HaiSoft) just tried the fix in Plesk Obsidian 18.0.18: While it kind of works in the sense that it now generates a proper SPF error, the custom SPF message has its "spaces" replaced by "%" signs, which makes it unreadable. We tried ecaping the spaces with "\" or using "%20" instead of spaces, which doesn't help solving this.

    So this is on the right way but not totally fixed :p

    Best regards

    0
    Comment actions Permalink
  • Avatar
    Robert

    Please post the default values for this spf setup

    0
    Comment actions Permalink
  • Avatar
    Leonid Gukhman

    @Robin Labadie Could you specify the OS version so I could pass this on to the developers?

    0
    Comment actions Permalink
  • Avatar
    Leonid Gukhman

    @Robert The 'SPF explanation text' line is empty by default.

    0
    Comment actions Permalink
  • Avatar
    Robin Labadie

    @Leonid Gukhman

    # cat /etc/centos-release
    CentOS Linux release 7.7.1908 (Core)

    I remain available if any more information is required. I would love to see this issue fixed. :)

    Best regards

    0
    Comment actions Permalink
  • Avatar
    Leonid Gukhman

    @Robin Labadie Since the bug is considered fixed, we would like to investigate this particular case. Let's continue it in the ticket that has been created (you should have received the notification).

    0
    Comment actions Permalink
  • Avatar
    Robin Labadie

    Thanks @Leonid Gukhman

    Following up into the ticket once we got a fresh install able to reproduce the issue then :)

    Best regards

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request