Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Unable to issue a Let's Encrypt certificate for a domain or Plesk, the process fails with the following error message:
Error: Could not issue a Let's Encrypt SSL/TLS certificate for example.com
The example.com DNS zone contains an AAAA record, but the domain is not assigned an IPv6 address in Plesk.
To resolve the issue, either assign an IPv6 address to example.com ("Websites & Domains" > "Web Hosting Access") or remove the AAAA record from the example.com DNS zone.
See the related Knowledge Base article for details.
Details
Invalid response from https://acme-v01.api.letsencrypt.org/acme/authz/qxK-vAPtGYg3YOSEcgZNB7HBd-unn4oX3GLtZWSxVPA.
Details:
Type: urn:acme:error:unauthorized
Status: 403 -
Domain or Plesk resolves to an IPv6 address:
# dig @8.8.8.8 +short -t AAAA example.com
2001:db8:f61:a1ff:0:0:0:80
Cause
Domain or Plesk resolves to an IPv6 address but the domain is not assigned or does not have an IPv6 in Plesk.
Resolution
There are two different solutions available, consider one of the following options:
-
Remove AAAA record from the domain/Plesk DNS zone or,
-
If the issue is with a domain, assign an IPv6:
-
Go to Domains > example.com > Web Hosting Access and assign an IPv6 to the domain.
-
If the issue is with Plesk interface, add an IPv6:
-
Go to Tools & Settings > IP Addresses and add an IPv6.
Comments
4 comments
If you're securing your domains with Cloudflare the problem can also caused by the configuration of SSL at Cloudflare.
Turn on "Full" unstead "Full (Strict)" mode, secure your domain and re-enable "Full (Strict)" after the issuing worked well.
always getting this, the cloudflare fix above, fixed it. Thanks.
Thansk Tino Korth | DrehPunkt GmbH solve my problem. It was exactly this configuration that was missing.
Thanks Tino Korth | DrehPunkt GmbH. I spent several hours doing this, I even removed the bind service from the server, thanks a lot for this.
Please sign in to leave a comment.