Symptoms
When pressing the Check All button in line Tools & Settings > Diagnose & Repair in Plesk Database, a warning appears:
The operation failed with the following error: {"id":1,"cmd":"plesk repair db -n","type":"progress","message":"Checking the Plesk database using the native database server tools","level":0} {"id":1,"cmd":"plesk repair db -n","type":"success","message":"Checking the Plesk database using the native database server tools","level":0} {"id":2,"cmd":"plesk repair db -n","type":"progress","message":"Checking the structure of the Plesk database","level":0} {"id":2,"cmd":"plesk repair db -n","type":"success","message":"Checking the structure of the Plesk database","level":0} {"id":3,"cmd":"plesk repair db -n","type":"progress","message":"Checking the consistency of the Plesk database","level":0} {"id":3,"cmd":"plesk repair db -n","type":"warning","message":"Checking the consistency of the Plesk database","level":0,"details":"Inconsistency in the table 'UserSettings' for the column userId: No rows in the table 'smb_users' with id = 5"} {"id":4,"cmd":"plesk repair db -n","type":"warning","message":"Inconsistency in the table 'smb_serviceInstances' for the column externalId: No rows in the table 'smb_apsInstances' with registryResourceId = 7edbb73e-aecb-4d07-bf53-cf5513b2a7b4","level":1} {"id":5,"cmd":"plesk repair db -n","type":"error","message":"Inconsistency in the table 'smb_serviceInstances' for the column externalId: There is no object in the 'apsc' database in the table 'aps_registry_object' with UID = 7edbb73e-aecb-4d07-bf53-cf5513b2a7b4","level":1}
1 issue(s) detected. Show issues
Cause
Inconsistency in Plesk psa database.
Resolution
- Log into Plesk
- Go to Tools & Settings > Diagnose & Repair
- Press the button Repair in the line Plesk Database
Note: In case the warning "Repair Kit fixed all issues it could. If any issues were not fixed, please try fixing them manually or contact Plesk Support." appears, fix issues manually via plesk repair db
command-line utility or submit a request to Plesk Technical Support.
Comments
6 comments
Hello
What should I do?
plesk repair db
RESULTS:
Checking the Plesk database using the native database server tools .. [OK]
Checking the structure of the Plesk database ........................ [OK]
Checking the consistency of the Plesk database
Inconsistency in the table 'apsResources' for the column registryId:
There is no object in the 'apsc' database in the table
'aps_registry_object' with UID =
fbaf8e97-f8ca-424b-81ad-e1c247afd4ee .............................. [ERROR]
Remove the corresponding rows from the table 'apsResources'? [Y/n]
Can I safely cancel it? Or not?
Hi Stefano Sudati yes you can cancel the task safely. The warning tells you that there are inconsistencies in the apsc database.
I recommend the following: backup psa and apsc via ssh:
Repair all inconsistencies with the -y option:
Hi Julian
Many Tnx
Could you please write to me if it didn't work how to go back?
Checking the consistency of the Plesk database
The following domains are assigned to already removed IP addresses.
Reassign the domains to existing IP addresses: .................................................................. [ERROR]
Error messages: 1; Warnings: 0; Errors resolved: 0
Dosnt work
Repair all inconsistencies with the -y option:
Database problem not solved
Hello Stefano Sabino,
Please open a support request. We will then investigate this specific problem in a support ticket.
Please sign in to leave a comment.