Server with Plesk Email Security no longer sends/receives emails: [127.0.0.1]:10024: Connection refused

Follow

Comments

20 comments

  • Avatar
    Martijn Van de Wetering

    You sir, just saved my life... Thank you very much! 👏🏼

    1
    Comment actions Permalink
  • Avatar
    Sysadmin

    In /var/log/maillog I get the same result and emails remain in the mail-queue, but I don't have the extension installed. ¿Any idea?

     

    1
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Hi Sysadmin 

    1. Please double check that it is indeed not installed under Home > Extensions.

    2. Then try to fix by rebuilding mail configuration, there is a chance redundant entries in config file left after removal: "plesk repair mail" 

    3. And if still no luck remove the below line from /etc/postfix/main.cf to disable manually amavis:

    content_filter = smtp-amavis:[127.0.0.1]:10024

    0
    Comment actions Permalink
  • Avatar
    Guido Mathiak

    Hi,

    i have the same issue, but Warden Anti-spam and Virus Protection installed. 

    The consequence of this solution would really be to uninstall to install Plesk Email Security 1.1.2-224?

    I have a valid licence for Warden.

    BR 

    Guido

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Hi Guido Mathiak! 

    Yes, you may uninstall from Home > Extensions 

    or by CLI from SSH:

    plesk bin extension --uninstall email-security

    0
    Comment actions Permalink
  • Avatar
    Sysadmin

    Hi Anton Maslov,

    Thanks! Works!

    0
    Comment actions Permalink
  • Avatar
    Jon (Edited )

    Still running in to trouble with this, started with the 1.1.1 release that broke things.

    Plesk Version: 18.0.29.

    Email Security Extension Version: 1.1.2-224

    I removed and reinstalled the extension, no luck.

    Tried plesk repair mail, plesk sbin mchk --without-spam, and checked the /etc/postfix/main.cf file - there is no content_filter line.

    I rebooted the system once for good measure.

    When I run postqueue -f, the log shows errors like this:

    Aug 8 04:26:53 blah postfix/error[5522]: 6892C8367A: to=<blah>, relay=none, delay=108470, delays=108470/0.11/0/0.01, dsn=4.3.0, status=deferred (mail transport unavailable)

    UPDATE: postsuper -r ALL, fixed the problem.
    0
    Comment actions Permalink
  • Avatar
    Bart Oevering

    Hi,

    For me this was not the Plesk Email Security extension but the MagicSpam Embedded Protection.

    Disable and then run the "postqueue -f" did the trick, thanks for helping me in the right direction.

    0
    Comment actions Permalink
  • Avatar
    Jan Bludau

    08-06-2020 - it stoped working.

    Aug 10 06:05:29 mail postfix/error[381492]: 185B2300B96AF: to=<jbludau@bludau-media.de>, relay=none, delay=239673, delays=239673/0.17/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    error: status=deferred (delivery temporarily suspended

    uninstall the plesk-emailserver security works well

    0
    Comment actions Permalink
  • Avatar
    Steve

    Hi. A week or two ago we clicked into the extension to see what it was about, and today found that our email was being deferred, as described above. We have followed the advice to uninstall the extension, but 20K emails are still deferred. Our /etc/postfix/main.cf doesn't have the filter line described. Do we need to "plesk repair mail" to kick the deferred emails back into being delivered, or do something else, please?

    0
    Comment actions Permalink
  • Avatar
    Steve

    Found the solution to knock them loose: "postsuper -r ALL", as above. Thanks.

    0
    Comment actions Permalink
  • Avatar
    Jan Bludau (Edited )

    now i receive emails with this message.

    This is the mail system at host mail.bludau-media.de.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <jbludau@bludau-media.de>: mail transport unavailable

    i didn't use the command postsuper

    mail:~# postsuper -r ALL
    postsuper: Requeued: 2137 messages

    0
    Comment actions Permalink
  • Avatar
    Jon

    So, on the 8th I posted about this and had resolved the issue.

    And on the 14th or 15th it started happening again... I didn't check first, but I'm betting Plesk Email Security 1.1.3 broke it again?

    status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    I was able to fix it by removing Plesk Email Security, then using: 

    postsuper -r ALL
    0
    Comment actions Permalink
  • Avatar
    Alexey Lapshin

    Hello @Jan Bludau

    If you still experiencing any issues, please submit a request to Plesk support: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-

    0
    Comment actions Permalink
  • Avatar
    Jan Bludau

    everything works right now.

    i forgot the 

    postsuper -r ALL

    if you don't use postuser you will receive this message:

    status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Jan Bludau

    Thank you for letting us know.

    0
    Comment actions Permalink
  • Avatar
    Fouad Ahmed Fouad

    This extension has bugs! I had to remove if off 3 servers, one Centos 8 server it flagged ALL mails as SPAM and no mail couldn't reach Inbox, on the second server it couldn't connect to its own Mysql database other than that it was working, then I had this strange issue, removing it solved all these issues.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Fouad Ahmed Fouad

    Thank you for the feedback. The extension is being polished.

    Feel free to create a support request next time you will have an issue with the extension.

     

    0
    Comment actions Permalink
  • Avatar
    Mathieu Peloquin

    I do not have Plesk Email Security installed, only Warden, and the same thing happened to me.  Unucky, I was away to a quiet place (no internet) for two days.  Auto-Updates enabled for plugins.  But it seems on Saturday morning at 1am, emails stopped working for some reason.  When I came back Sunday evening, I saw there was an issue as absolutely no emails were going thru.  I have found this article, updated the Warden plugin and everything came back to normal.

    Now I am wondering why is there no mechanism to prevent that behavior from happening, and also why would the plugin not be updated for 2 days in a row when auto-updates were enabled?

    Anyone knows?

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Mathieu Peloquin Hi! Warden also uses amavis that's why error might look similar. Please try to fix the issue just by starting this service:

    service amavisd start

    If won't help I do recommend to get in touch with their support.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request