Applicable to:
- Plesk Obsidian for Linux
Symptoms
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Server with Plesk Email Security no longer sends/receives emails
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Emails remain in the mail-queue at Tools & Settings > Mail Server Settings > Mail Queue
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Plesk Email Security was recently updated to version 1.1.1-223 as per Tools & Settings > Action log:
CONFIG_TEXT: 'Upgrade extension' ('Extension Id': 'email-security' => 'email-security', 'Extension Name': 'Plesk Email Security' => 'Plesk Email Security', 'Extension Release': '216' => '223', 'Extension Version': '1.1.0' => '1.1.1')
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In mailserver logs under
/var/log/maillog
the below message also can be found:CONFIG_TEXT: Aug 5 15:50:37 server postfix/error[5528]: A898A3FEA9: to=jdoe@example.com, relay=none, delay=0.19, delays=0.18/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Cause
Product issue:
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#EXTCERT-3028 "Postfix strict rules are not applied automatically and are removed in the update process"
Fixed in:- Plesk Email Security 1.1.2-224 06 August 2020
Resolution
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Update Plesk Email Security extension.
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Open the extension to install the required components by going to Extensions > My Extensions > Plesk Email Security>Install
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Connect to the server via SSH
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Re-queue emails:
# postsuper -r ALL
If the same issue exists but another steps are needed to fix the issue, for example re-install PES extension then create a new article. Most probably it has another cause that should be found.
Comments
24 comments
You sir, just saved my life... Thank you very much! 👏🏼
In /var/log/maillog I get the same result and emails remain in the mail-queue, but I don't have the extension installed. ¿Any idea?
Hi Alphamega
1. Please double check that it is indeed not installed under Home > Extensions.
2. Then try to fix by rebuilding mail configuration, there is a chance redundant entries in config file left after removal: "plesk repair mail"
3. And if still no luck remove the below line from /etc/postfix/main.cf to disable manually amavis:
Hi,
i have the same issue, but Warden Anti-spam and Virus Protection installed.
The consequence of this solution would really be to uninstall to install Plesk Email Security 1.1.2-224?
I have a valid licence for Warden.
BR
Guido
Hi Guido Mathiak!
Yes, you may uninstall from Home > Extensions
or by CLI from SSH:
plesk bin extension --uninstall email-security
Hi Anton Maslov,
Thanks! Works!
Still running in to trouble with this, started with the 1.1.1 release that broke things.
Plesk Version: 18.0.29.
Email Security Extension Version: 1.1.2-224
I removed and reinstalled the extension, no luck.
Tried plesk repair mail, plesk sbin mchk --without-spam, and checked the /etc/postfix/main.cf file - there is no content_filter line.
I rebooted the system once for good measure.
When I run postqueue -f, the log shows errors like this:
Hi,
For me this was not the Plesk Email Security extension but the MagicSpam Embedded Protection.
Disable and then run the "postqueue -f" did the trick, thanks for helping me in the right direction.
08-06-2020 - it stoped working.
Aug 10 06:05:29 mail postfix/error[381492]: 185B2300B96AF: to=<jbludau@bludau-media.de>, relay=none, delay=239673, delays=239673/0.17/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
error: status=deferred (delivery temporarily suspended
uninstall the plesk-emailserver security works well
Hi. A week or two ago we clicked into the extension to see what it was about, and today found that our email was being deferred, as described above. We have followed the advice to uninstall the extension, but 20K emails are still deferred. Our /etc/postfix/main.cf doesn't have the filter line described. Do we need to "plesk repair mail" to kick the deferred emails back into being delivered, or do something else, please?
Found the solution to knock them loose: "postsuper -r ALL", as above. Thanks.
now i receive emails with this message.
i didn't use the command postsuper
mail:~# postsuper -r ALL
postsuper: Requeued: 2137 messages
So, on the 8th I posted about this and had resolved the issue.
And on the 14th or 15th it started happening again... I didn't check first, but I'm betting Plesk Email Security 1.1.3 broke it again?
I was able to fix it by removing Plesk Email Security, then using:
Hello @Jan Bludau
If you still experiencing any issues, please submit a request to Plesk support: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
everything works right now.
i forgot the
if you don't use postuser you will receive this message:
Hello Jan Bludau
Thank you for letting us know.
This extension has bugs! I had to remove if off 3 servers, one Centos 8 server it flagged ALL mails as SPAM and no mail couldn't reach Inbox, on the second server it couldn't connect to its own Mysql database other than that it was working, then I had this strange issue, removing it solved all these issues.
Hello Fouad Ahmed Fouad
Thank you for the feedback. The extension is being polished.
Feel free to create a support request next time you will have an issue with the extension.
I do not have Plesk Email Security installed, only Warden, and the same thing happened to me. Unucky, I was away to a quiet place (no internet) for two days. Auto-Updates enabled for plugins. But it seems on Saturday morning at 1am, emails stopped working for some reason. When I came back Sunday evening, I saw there was an issue as absolutely no emails were going thru. I have found this article, updated the Warden plugin and everything came back to normal.
Now I am wondering why is there no mechanism to prevent that behavior from happening, and also why would the plugin not be updated for 2 days in a row when auto-updates were enabled?
Anyone knows?
Mathieu Peloquin Hi! Warden also uses amavis that's why error might look similar. Please try to fix the issue just by starting this service:
service amavisd start
If won't help I do recommend to get in touch with their support.
Hello Anton Maslov,
Thanks for your reply! Unfortunately, I had tried restarting all email, spam and virus related services without any luck (systemctl restart amavis). The only trick that did it instantly was clicking the "update plugin" button next to the Warden plugin. As written in my previous comment, what I don't understand is why would the plugin not be updated for two days in a row, considering there was a new version available and the "Auto Update Plugins" button was "ON"?
I am a bit stressed out that this situation will happen again upon new versions of the plugin and that part does not seem to be only related to the plugin itself but to the auto-update mechanism of Plesk also if I am not mistaken.
Hello Mathieu Peloquin extension should be updated automatically. It is required to create a ticket to check on why it did not happen automatically.
I am not sure why, in my case, amavis could not access the database "emailsecurity" because the user configured in "/etc/amavisd/email-security.conf" was not configured in MariaDB. So I added the permissions of this user to the database and now it is working again.
This started two days ago. I don't know if it was after an update or something else (I haven't really done anything on the server, so it was either automatic or I can't explain it). But with this operation the problem is solved.
Hello Nerque
Probably you've been affected by this bug.
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