Applicable to:
- Plesk Onyx for Linux
Symptoms
-
Plesk > Acronis Backup fails with the following error:
CONFIG_TEXT: The backup service is not available.
Please contact your service provider. -
The following error can be found in
/var/log/plesk/panel.log
:# less /var/log/plesk/panel.log
ERR [extension/acronis-backup] Response with error has been received. Request: {"jsonrpc":"2.0","method":"getPermissions","id":"5c36464194a03"} Response: {"id":"5c36464194a03","error":{"message":"Timeout exceeded (MMS)","code":-32050}} -
The following error can be seen in
/usr/local/psa/var/modules/acronis-backup/srv/log/main.log
:# less /usr/local/psa/var/modules/acronis-backup/srv/log/main.log
[INFO] SrvResponse: {"result": {"isContainer": true, "backupAgentRequiredPackages": ["rpm", "perl", "linux-headers-3.16.0", "linux-image-3.16.0", "gcc", "make", "dmsetup", "parted"], "needConfigureApparmorForMySql": false, "linuxDistr": "debian", "isSupportedForBackupAgent": true, "backupAgentExists": false}, "jsonrpc": "2.0", "id": "5c36492aada18"} -
Plesk is installed in a Virtuozzo/OpenVZ Container :
# hostnamectl status | grep Virtualization
Virtualization: openvz
Cause
Acronis Backup agent has to be deployed in the Virtuozzo/OpenVZ hardware node and not in the container as described here.
Resolution
Contact Acronis Support in order to install the Acronis Backup Agent in the hardware node: Installing Agents.
If it is not possible to manage the Virtuozzo host, check out other Plesk backup solutions available: What Plesk backup cloud solutions are available in Plesk and how to use them?
Comments
1 comment
We got the same error after upgrading Acronis to agent version 15.0.31286.
We also got the error "Registration server address is not equal to uplink address" in Acronis MMS logs.
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