[FIXED BUG] Images from a WordPress website in Plesk are broken and replaced with the following one: "Stop! This image was hotlinked"

Follow

Comments

6 comments

  • Avatar
    Motaz Elshazly

    I am using the latest version (Onyx 18.20) and still seeing the same issue, please advise on how to disable this feature, I tried disabling it from the WP Kit but it's still blocking the images. please advise, thank you!

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Hi Motaz, if you disabled that in WP Toolkit make sure that:

    1. It is not website cache, try e.g. opening in incognito mode.

    2. Make sure there are no 3rd part plugins that also enable hotlink protection

    3. Make sure you are not loading images from another website.

    0
    Comment actions Permalink
  • Avatar
    Ian Brown

    The problem I had was that the domain was served from https://mydomain.com but the images were linked to https://www.mydomain.com. Looking at Google Chrome, it showed mydomain.com in the address bar, so it could be easily missed that you aren't using the www. or vice versa.

    To fix a WordPress site, I used the "WP Migrate DB" plugin. This allowed me to run a text replace on all the www. instances in the DB tables. If you have any cache or speed boost plugins installed, remember to clear the cache after too.

    0
    Comment actions Permalink
  • Avatar
    Lev Iurev

    @Ian Brown

     

    Thanks for sharing, it can be useful

    0
    Comment actions Permalink
  • Avatar
    Jason Koning (Edited )

    I potentially, have a slightly different issue, mine is a multisite installation, images load find on the main site, but any sub sites have the image hotlinking issue.
    Thus far, I've had no luck getting on top if this.

    Anyone have any advice/suggestions?

    This is using sub-domains for the sub sites, so *.domain.com (for example).

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Jason Koning

    In your case, the root cause seems to be different and deeper investigation is required.

    You may submit a request for Plesk Support: https://support.plesk.com/hc/en-us/articles/213608509 to have it check from support side, maybe there will be some suggestions.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request