Symptoms
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Attempt to open domain in Plesk UI fails with the error:
CONFIG_TEXT: Server Error
500 Error
Call to a member function getStatus() on null
Type Error
Message Call to a member function getStatus() on null
File DomainEntity.php
Line 307 -
In Plesk log
%plesk_dir%\admin\php_error.log
on Windows and/var/log/plesk/panel.log
on Linux the error refers to SSL It! extension:CONFIG_TEXT: ERR [panel] Error: Call to a member function getStatus() on null
file: C:\Program Files (x86)\Plesk\admin\plib\modules\sslit\library\Entity\Domain\DomainEntity.php
line: 307
code: 0
trace: [#0](/agent/tickets/0) C:\Program Files (x86)\Plesk\admin\plib\modules\sslit\vendor\symfony\cache\LockRegistry.php(98): PleskExt\SslIt\Entity\Domain\DomainEntity->PleskExt\SslIt\Entity\Domain\{closure}(object of type Symfony\Component\Cache\CacheItem, boolean true) -
SSL support is disabled for a domain:
For Windows:
C:\> plesk bin site -i example.com | findstr SSL
SSL/TLS support: OffFor Linux:
# plesk bin site -i example.com | grep SSL
SSL/TLS support: Off
Cause
Product issue:
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#EXTSSLIT-954 "When a domain was secured with an SSL/TLS certificate and then the SSL support for the domain was disabled, the “Websites & Domains” page for the domain is now opened without any issues."
Fixed in:- SSL It! 1.4.1 05 June 2020
Resolution
Workaround
If Plesk GUI is accessible to you then update the SSL It! extension to the latest version.
If Plesk GUI is not accessible due to this bug, then follow these steps to update SSL It! extension to the latest version:
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Connect to the server via SSH
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Run this command to initiate update of the extension:
# /usr/local/psa/bin/sw-engine-pleskrun /usr/local/psa/admin/plib/DailyMaintainance/script.php -f UpgradeExtensions
Or:
If update is not possible for some reason, as a workaround, enable and disable the SSL support for the affected domain or subdomain:
Note: For subdomain, replace the example.com with the subdomain.example.com. The command to be used is the same.
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Connect to the server via SSH
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Enable the SSL support to the affected domain:
# plesk bin site -u example.com -ssl true
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Disable back again the SSL support to the affected domain:
# plesk bin site -u example.com -ssl false
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Connect to the server via RDP
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Enable the SSL support to the affected domain:
C:\> plesk bin site -u example.com -ssl true
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Disable back again the SSL support to the affected domain:
C:\> plesk bin site -u example.com -ssl false
Alternatively, temporarily disable the SSL It! extension:
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Go to Extension > My Extensions > Click on the SSL It! icon > Open > More > Disable
Comments
6 comments
we have this on most of our shared hosting servers.
Can you post on these comments once the bug is fixed as we've disabled ssl it on all servers
Lame that this just broke as of the patch yesterday. What command can do this for all domains on a server instead of just one at a time?
For all domains please use the following as per Martin Dias - Support Agent
for i in `plesk db -Nse "select d.name from domains as d join hosting as h where h.ssl='false' and h.dom_id=d.id;"`; do plesk bin domain -u $i -ssl true; done
Thank u
but how I know what domain is affected?
is the command line for Linux?
Hello Christopher Danks Shawn Carron Bassl KHia
Sorry for the late response. The fixed version of the extension was released later on the 5th of June. Updating the extension should fix the issue.
@Bassl KHia that command I posted is for Linux CLI. My apologies I should have been more clear on that.
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