Applicable to:
- Plesk Obsidian for Linux
Symptoms
-
Simple redirect to
index.php
does not work inside/var/www/vhosts/example.com/httpdocs/folder/.htaccess
:CONFIG_TEXT: RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php [QSA,L] -
http://example.com/folder shows
CONFIG_TEXT: 404 Not Found
-
Domain log shows the following error:
CONFIG_TEXT: [core:error] [pid 6919:tid 139826242234112] [client *****:50002] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: https://example.com/wp-admin/
-
The following error may appear while trying to repair the affected domain:
CONFIG_TEXT: DEBUG [panel] Template_Exception:
AH00526: Syntax error on line 158 of
/etc/apache2/plesk.conf.d/vhosts/example.com.conf:
Regex could not be compiled
Cause
Plesk bug with ID #EXTWPTOOLK-5009. The fix has been issued in Wordpress Toolkit 4.8.2 version.
Resolution:
Update WordPress Toolkit to version 4.8.2 to fix the issue:
- Home > Extensions > Updates > Check now.
- Select Wordpress Toolkit and click Update
- Previously disabled security measures can be now enabled back. Home > Wordpress Toolkit > Installation Tab > Security > Select All instances > Secure> check options "Enable hotlink protection", "Block authors scan" and "Enable bot protection" and click "Secure".
Comments
14 comments
¡IT DOESN'T WORK!
Después de actualizar WordPress Toolkit a 4.8.1 ejecuto plesk repair web y en todas las webs del servidor dejan de funcionar los redireccionamientos, esto es un problema muy muy grave.
Re-apply these security measures will break.
I had to leave those 2 unsecured for the site to work.
Furthermore, I think subdomain within the same subscription which doesn't have WP but still use .htaccess rewrite rule also breaks because of this bug and don't know how to fix that particular subdomain because it isn't WP site, thus no WPToolKit.
I have 404 errors on all the pages of several sites located in a sub-domain.
I tested the "workaround" solution but in my case it does not solve the problem.
I am on WPTOOLKIT version 4.8.1-3636 and 18.0.26 PLESK.
A faster way to do it 1 site at a time is the following:
So let's do the following it then, let's revert all changes done on the instances.
1. Extensions > Wordpress Toolkit > Installation Tab > Security > Select All instances > Revert > Enable hotlink protection, Block authors scan and Enable bot protection
2. Run plesk repair web -y on CLI
Hi all,
Please execute also web server reconfiguration:
Tools & Settings > Diagnose & Repair > Web & FTP Servers > Repair
Or the same from SSH:
plesk repair web -y
I just performed the procedure on ALL sites, then I execute "plesk repair web -y" command via SSH and it works now.
Thanks Anton
This solution is only for vhosts that have WP Toolkit. What about vhosts that have installed WordPress without WP Toolkit?
Hi Ion, Wordpress domains without WP Toolkit can be affected in case there is another domain under the same subscription which has WP Toolkit instance installed. The same steps to disable security measures and do reconfiguration should also solve instances not from WP Toolkit as well.
Ahh, there was a subdomain I've missed. Thanks, this fixed the issue.
This issue is happening also in Plesk Onyx.
After a upgrade from Plesk Onyx to Obsidian its needed to follow this instructions and upgrade the WordPress Toolkit.
Thanks for the fix.
wow, it's been a nightmare trying to troubleshoot this across two servers overnight. trying this fix now! the only workaround i had found was switching php from FPM served by Apache to FPM served by Nginx.
Yay- it worked to fix the first domain I tried it on, Denit Support, thanks!
This was driving me nuts, only affecting one site out of many, and I use WordPress toolkit on them all, but perhaps bot protection or block authors was not enabled, not sure.
The updated toolkit resolved the issue for me!
I am still having issues. I did everything mentioned above and nothing. Took me a while to find this as well. Any other suggestions?
Hello Nickea
As I can see, you've contacted support and the issue was resolved.
The cause was web server misconfiguration.
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