Applicable to:
- Plesk for Linux
Symptoms
-
Mailbox is disabled for mail account (No mailbox) under Domains > example.com > Mail Accounts;
-
However, mail account receives and stores emails;
-
The same can be seen over Plesk CLI:
# plesk bin mail -i jdoe@example.com
Mailname: jdoe
Domain: example.com
Mailbox: false
...
Same can be observer over Plesk database (PSA):
MYSQL_LIN: MariaDB [psa]> select u.email, m.postbox from smb_users u, mail m where u.id = m.userId and email = 'jdoe@example.com';
+-----------------------------------+---------+
| email | postbox |
+-----------------------------------+---------+
| jdoe@example.com | false |
+-----------------------------------+---------+
1 row in set (0.00 sec)
Cause
Database inconsistency.
Resolution
-
Go to Extensions, search for Repair Kit extension, and install it.
-
Go to Tools & Settings > Diagnose & Repair.
-
Click Repair next to Mail Server:
-
Connect to the server via SSH.
-
Restore mail server configuration for the affected domain using the following command:
# plesk repair mail example.com
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