Applicable to:
- Plesk Obsidian for Linux
- Plesk Obsidian for Windows
Symptoms
-
Advanced Monitoring graphs are empty.
-
Grafana 7.0.0 is installed:
# rpm -qa | grep grafana
grafana-7.0.0-1.x86_64
# dpkg -l | grep grafana
ii grafana 7.0.0 amd64 Grafana
C:\> "%plesk_dir%var\modules\grafana\grafana\bin\grafana-server.exe" -v
Version 7.0.0 (commit: a04ef6cefc, branch: HEAD)
Cause
Product issue:
-
#EXTPLESK-1867 "Resolved compatibility issues with Grafana 7.0."
Fixed in:- Grafana 1.1.5 19 May 2020
Resolution
Workaround
-
Connect to the server using SSH as root.
-
Back up the file
/etc/grafana/grafana.ini
:# cp -p /etc/grafana/grafana.ini /etc/grafana/grafana.ini_back
-
Edit the file
/etc/grafana/grafana.ini
adding the following lines to the end of the file:CONFIG_TEXT: [plugins]
allow_loading_unsigned_plugins = grafana-simple-json-backend-datasource -
Restart service:
# service grafana-server restart
-
Connect to the server using RDP as Administrator.
-
Back up the file
%plesk_dir%var\modules\grafana\grafana\conf\custom.ini
. -
Edit the original file
%plesk_dir%var\modules\grafana\grafana\conf\custom.ini
adding the following lines to the end of the file:CONFIG_TEXT: [plugins]
allow_loading_unsigned_plugins = grafana-simple-json-backend-datasource -
Restart Grafana service: open Windows services with [Win + R], type
services.msc
, then right-click on Grafana and click Restart.
Comments
2 comments
just added the line to the end of /etc/grafana/grafana.ini file
restarted per instrutions - still stalling. It was ending up with a specific "Grafana Server Error" message - that no longer is appearing. Now getting
restarted plesk - nada
updated to grafana 7.03, restarted grafana server - nada
What is the fix on this please?
Hello, @webmaster
Please try to clear browser cache/cookies oк check with another browser.
If the issue persist - submit a ticket to us https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
Please sign in to leave a comment.