Applicable to:
- Plesk for Linux
Symptoms
-
Emails from a Plesk server are not sent. The following records appear in
/var/log/mailllog
:CONFIG_TEXT: connect to aspmx.l.google.com[203.0.113.2]:25: Connection timed out
plesk postfix/smtp[17181]: connect to aspmx.l.google.com[2001:db8:f61:a1ff:0:0:0:80]:25: Network is unreachable
plesk postfix/smtp[17181]: connect to alt2.aspmx.l.google.com[203.0.113.2]:25: Connection timed out
plesk postfix/smtp[17181]: connect to alt2.aspmx.l.google.com[2001:db8:f61:a1ff:0:0:0:80]:25: Network is unreachable -
It is possible to connect to a remote host on port 25 using the telnet utility:
# telnet alt2.aspmx.l.google.com 25
...
Trying 74.125.28.26...
Connected to alt2.aspmx.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP c68si1753439pfa.129 - gsmtp
Cause
A private IP address is used for outgoing emails.
Resolution
-
Go to Tools and Settings > Mail Server Settings.
-
Set Outgoing mail mode to some public IP address.
Comments
2 comments
Daniel Pereyra, thank you for sharing your experience, some other Plesk users may find it helpful!
This solved my issue of emails getting stuck on queue.
I'm using DigitalOcean as cloud provider and the Plesk package (https://marketplace.digitalocean.com/apps/plesk), as default on Tools and Settings > Mail Server Settings > Outgoing mail mode, was set to "Send from domain IP addresses".
I think in my case, as the domains are using a floating IP, the server stop sending emails. I have set the Outgoing mail mode to the droplet IP address and now is working. I have also discovered that I had other messages in queue from the date I have changed to floating IP use.
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