[FIXED BUG] Unable to perform migration: Unable to find archive metadata. The archive is not valid Plesk backup or has been created in an unsupported Plesk version

Follow

Comments

37 comments

  • Avatar
    Gianluca

    Hi, my destination server has a new installed Plesk 18.0.27 version and the source server has Plesk 18.0.26 , i received that error, is the same situation? So the issue is related to the extension Migrator and Plesk 18.0.27?

    0
    Comment actions Permalink
  • Avatar
    Erik Blazynski

    This is not working again in 18.0.27   Same version on both servers. 

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov (Edited )

    Hi Erik Blazynski and Gianluca.

    Yes, the issue occurs if on destination server you have 18.0.27, source version can be any.

    Most suitable workaround at this moment is to do backup on source, upload it to destination to move data.

    We working on permanent fix with high priority here and expect to issue it in a couple of days.

    0
    Comment actions Permalink
  • Avatar
    Alex Vojacek

    In a couple of days !?!.   I'm sorry but that's unacceptable.  You completely broke the migration.  I now have to do a migration of several domains to a new server which is due this week and backup/restore is completely broken.

    I've followed your advice to do a CLI manual backup and then restore,  I'm doing a perfect backup and copy of the content to destination server, both servers are on 18.0.27 and when trying to restore it says I have corrupted databases so the manual method DOES NOT WORK either !!

    3
    Comment actions Permalink
  • Avatar
    Erik Blazynski

    Thank you for responding. How can I be notified when the fix is available? 

    0
    Comment actions Permalink
  • Avatar
    Alex

    +1. please, roll out a solution asap

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Erik Blazynski you may click "follow" to subscribe for updates. Once fix is available article will be updated.

    Alex Vojacek Please rest assured it is highest priority and fix will be delivered ASAP. If you can paste full error about database restore we may take a look.

    0
    Comment actions Permalink
  • Avatar
    Alex Vojacek (Edited )

    It gives all kinds of errors.  If I export from a normal backup and try to import from the CLI it imports the sites but tells me that all my databases are corrupted. 

    If I export from CLI on the origin server with your method and then ftp the file to the destination server and try to do an import, it throws this error after what appears to be a full import.

     

    Unable to import file as dump: pmm-ras failed (Error code = 1): Transport error: 0 byes were read but 65304394 expected.

     

    I suspect the problem appears to be coming from the backup process itself, not restore process.

    This is so easy to replicate now:

    Do a backup with:

     

    plesk bin pleskbackup --domains-name mydomain.com --output-file="/root/example.com.zip" -v

     

    Then try to check that newly created backup with:

     

    plesk bin pleskrestore --check-backup "example.com.zip"

     

    You'll see the same error show up:

    Unable to import file as dump: pmm-ras failed (Error code = 1): Transport error: 0 byes were read but 65304394 expected.

     

    So it seems the problem starts at the backup creation phase, that is the only explanation I can come up with for this sorts of errors. I've never had a single backup/restore or migration issue before.

    My domain has 25GB of compressed data,  so it seems like your basic backup/restore functionality is either not working at all or just breaks with big backups. 

    There is no way to do a backup/restore, not with your methods, not by manually inserting the backup files, there is just not a single method that works, period.

    You need to issue an update that reverts to the 18.0.26 behavior ASAP and then concentrate on fixing it for good, because as it is,  we have lost the migration backup/restore funcionality completely.

     

     

    0
    Comment actions Permalink
  • Avatar
    Michel vd Lingen

    I reported the issue yesterday and thus this [BUG] was created. Can only hope this is resolved as soon as possible with the highest urgency.
    These bugs should really not happen with sufficient testing in the near future.

    0
    Comment actions Permalink
  • Avatar
    Abdelrahman Moussa

    Can you guys disable the ability for people to upgrade until the bug is fixed? I think it will help reduce the amount of people that can get in trouble over this.

    0
    Comment actions Permalink
  • Avatar
    HMnet (Edited )

    Hey!

    Same problem here.

    I wan't to migrate from 12.5.30 to 18.0.27...
    I have to migrate 150 clients with websites ans email, so workaround 1 is no option!

    Please fix the bug very soon!

    Greetings!

    0
    Comment actions Permalink
  • Avatar
    Claus Siebeneicher

    The backup-restore suggestion is far from straight forward.

    Needs appently a lot of manual confilict resolution. Like many others here, I would appreciate an ASAP solution - stuck in an emergency migration and doing it on site/file lovel now...

    0
    Comment actions Permalink
  • Avatar
    Pete Murphy

    Thaks for fix ASAP. Regards.-

    0
    Comment actions Permalink
  • Avatar
    Sander Scheer

    Any prediction when this will be fixed? I'm migrating away a couple of VPS's from Str*to since they have serious performance issues, but now migrating is really a pain since I can't use the migrator.

    0
    Comment actions Permalink
  • Avatar
    Markus Plänitz

    +1

    Workaround 2 only works if the source is not already version 18.0.27. 

    A updated migration manager would be very much appreciated.  

     

    0
    Comment actions Permalink
  • Avatar
    Alex Vojacek

    After finally being able to downgrade the destination server and when I try to start the migration,  this is what I get.

    You guys did a great job pushing me into a corner where now I have to manually move each domain files and databases by hand.

    0
    Comment actions Permalink
  • Avatar
    Julian Bonpland Mignaquy

    @Alex Vojacek @Markus Plänitz @Sander Scheer @Pete Murphy @Claus Siebeneicher @HMnet @Abdelrahman Moussa @Michel vd Lingen.

     

    The bug has been fixed and the resolution has been added to the article. Please proceed by updating Plesk Migrator and let us know.

    0
    Comment actions Permalink
  • Avatar
    Julian Bonpland Mignaquy

    Alex Vojacek please update your destination server to 18.0.27 and then migration from the old server. The bug has been fixed.

    0
    Comment actions Permalink
  • Avatar
    Pete Murphy

    Thank you for this good work and fast work. Thank you very much!

    0
    Comment actions Permalink
  • Avatar
    Alex Vojacek

    THANK YOU !!! 

    0
    Comment actions Permalink
  • Avatar
    Khairul Hasan

    I'm getting the error while trying to migrate my sites from cPanel to Plesk. The current Plesk Migrator version is 2.19.2-916. Please solve the issue. Thanks.

    0
    Comment actions Permalink
  • Avatar
    Khairul Hasan

    My issue seems to be resolved after updating to version 2.19.3

    0
    Comment actions Permalink
  • Avatar
    Claus Siebeneicher

    Thank you for the quick action, Julian!

    0
    Comment actions Permalink
  • Avatar
    Alex Vojacek (Edited )

    So far so good,  although I'm getting this error after several attempts.

     

    Failed to perform an action on subscription 'a****r.com': Failed to transfer additional Apache/nginx directives Exception message: Migration tools tried to perform operation in 3 attempts: Command LANG=en_US.UTF-8 ALLOW_WEAK_PASSWORDS=1 PLESK_RESTORE_MODE=1 backup_restore_helper --restore-subscription agsdevserver.com -ignore-nonexistent-options failed with exit code 1: stdout: stderr: Unknown command: --restore-subscription

     

    It seems migration is still going so it is not a fatal error.

    0
    Comment actions Permalink
  • Avatar
    Alex Vojacek

    It worked !.  Aside from that minor issue my server is now migrated. Thank you so much !

    0
    Comment actions Permalink
  • Avatar
    Erik Blazynski

    Still not working. 

    "Failed to make APS applications dump. Not all applications data may be migrated.
    Error message: Command execution failed on the local server with non-zero exit code" 

    "Failed to create the remote configuration dump on the target server. Not all settings may be migrated.
    Error message: Command execution failed on the local server with non-zero exit code." 

    This used to work just fine.. can you please advise? 

    0
    Comment actions Permalink
  • Avatar
    Alex

    I moved data from Centos 7 to Ubuntu a couple of days ago (Plesk 18.0.26) and never got errors.

    Updated to 18.0.27+Migrator tonight. Again moving data from Centos 7 to Ubuntu 18.04. Test run shows weird errors.

    0
    Comment actions Permalink
  • Avatar
    gregtoffer

    The new version brings a new error

    Failed to transfer additional Apache/nginx directives
    Migration tools tried to perform operation in 3 attempts: Command LANG=en_US.UTF-8 ALLOW_WEAK_PASSWORDS=1 PLESK_RESTORE_MODE=1 backup_restore_helper --restore-subscription xxxxx.net -ignore-nonexistent-options failed with exit code 1:
    stdout:
    stderr: Unknown command: --restore-subscription

    Any ideas?

    0
    Comment actions Permalink
  • Avatar
    Anzhelika Khapaknysh

    @Alex Vojacek, @Alex, @gregtoffer,

    Thanks for bringing this to our attention!
    Here's the article about the issue: https://support.plesk.com/hc/en-us/articles/360013860439 

    The solution is the same: update Plesk Migrator to version v2.19.3 

    0
    Comment actions Permalink
  • Avatar
    Alejandro Betancor

    Anzhelika Khapaknysh

     

    I still have the error

     

    Failed to transfer additional Apache/nginx directives
    Migration tools tried to perform operation in 3 attempts: Command LANG=en_US.UTF-8 ALLOW_WEAK_PASSWORDS=1 PLESK_RESTORE_MODE=1 backup_restore_helper --restore-subscription orcafusioncreativa.com -ignore-nonexistent-options failed with exit code 1:
    stdout:
    stderr: Unknown command: --restore-subscription

     

    even though am in the latest version of the migrator

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request