Which MariaDB versions are supported by Plesk?

Follow

Comments

10 comments

  • Avatar
    Boyan

    This article needs to be updated to reflect that Plesk Obsidian 18.0.30 now supports up to MariaDB 10.5.

    0
    Comment actions Permalink
  • Avatar
    Alisa Kasyanova

    @Boyan

    Thank you for your comment, I have updated the article accordingly

    0
    Comment actions Permalink
  • Avatar
    Gerwin Janssen

    I have installed Plesk Obsidian 18.0.30 but MariaDB is on version 10.1.46. How to upgrade to 10.3 or higher?

    0
    Comment actions Permalink
  • Avatar
    Vitaly Zhidkov

    Gerwin Janssen

    Plesk does not upgrade the DB server and it should be upgraded manually. Please see article for detailed instructions

     

    0
    Comment actions Permalink
  • Avatar
    Markus Faber

    Hello,

    what will happen with Plesk Onyx (Linux), when MariaDB 10.3 will be updated manually on CENTOS 7 ?

    The point is, we have access to Plesk Onyx with CENTOS 7 only, but Shopware 6 has requirements of at least MariaDB 10.3 or MYSQL 5.7 for installation.

     

    Thanks for hints.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Markus Faber

    I would recommend upgrading Plesk to the Obsidian first of all. The upgrade process usually goes smoothly.

    Plesk Onyx wasn't tested with MariaDB 10.3. Plesk Onyx should work with it but there's no guarantee that no issue will appear.

    0
    Comment actions Permalink
  • Avatar
    Markus Faber

    Ivan Postnikov,

    Thanks for your suggestion.

    The Point is, my Hoster has only an Onyx license included in the package. If I want to have Obsidian, I have additional costs for the newer version.

    That means in fact, upgrading is no option at this point.

     

    0
    Comment actions Permalink
  • Avatar
    Dilan Rostam

    I have Plesk Obsidian 18.0.31 and the new Drupal 9 requires MariaDB 10.4+, how do I get my version 10.1 to 10.4 please? Do you hav any plan to make this possible via your regular Plesk update soon?

    I run my Plesk on

    • OS: ‪Debian 9.13‬

     

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Markus Faber the same license can be used on Onyx and Obsidian means you should be able to upgrade Plesk without additional costs, unless you have "perpetual" license. Like my colleague Ivan mentioned MariaDB 10.3 can work only with Obsidian. You may try to create full server snapshot, update MariaDB and see if it works with Onyx, however it will make installation as not supported.

    0
    Comment actions Permalink
  • Avatar
    Anton Maslov

    Dilan Rostam At this moment Plesk automatically install version provided by OS itself, Debian 9 goes with 10.1. In order to update you may use this guide.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request