Applicable to:
- Plesk for Linux
Symptoms
-
A customer with a subscription was created in Plesk when the component BIND DNS server was not installed.
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After installing BIND DNS server, the following error is shown upon changing the email address of that customer in Plesk in Customers > John Doe > Edit Contact Info:
PLESK_ERROR: Error: Incorrect DNS zone parameters were specified.('displayName' = '', 'name' = '')
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The customer's email address is actually changed.
Cause
Product issue:
- #PPPM-9775 "Changing the email address of a customer account no longer results in an error if the DNS server component is installed, but was not installed at the moment of the customer’s creation."
Fixed in:- Plesk Obsidian 08 May 2019 (fixed as PPP-39779, Linux)
Resolution
Please consider updating your server:
Workaround
Until the bug is fixed, use the workaround:
Click on a section to expand
In Plesk interface
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Go to Domains > example.com > DNS Settings an click Reset to Default.
In CLI
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Connect to the server using SSH.
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Execute the command:
# plesk bin dns -res example.com -ip 203.0.113.2
where 203.0.113.2 is the IP address assigned to the domain.
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