Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Website is inaccessible with the following error message:
CONFIG_TEXT: www.example.com's server IP address could not be found
-
On attempts to access the website by its IP, the default Plesk Web server Page is shown
-
For the domain
example.com
, the A record on IP address of the domain at Plesk exists, forwww.example.com
- does not existNote: It is possible to check the IP address of the domain by logging into Plesk and going to Domains > example.com > Web Hosting Access.
Cause
A DNS settings misconfiguration on a domain. Missing CNAME record on NS servers.
Resolution
Add the CNAME record on used NS servers, e.g:
CONFIG_TEXT: www.example.com CNAME example.com
Note: It can be possibly required to contact a domain registrar or DNS service provider to add the record on nameservers.
- Log into Plesk
- Go to Domains > example.com > Hosting Settings
- Select non-www URL under the Preferred domain option
Comments
5 comments
Hi!,
we have a DNS problem with a fresh plesk 18.0.30 installation an a Debian 10 Server. The Plesk Bind DNS refused all valid request. A dig query shows that:
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 18691
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available
What could be the reason?!
Regards, betei
Hi there Betei Geuze!
Thanks for your question.
I've checked this on a test server with Plesk and Debian 10 and DNS works fine there.
The issue you have faced might be caused by filtered port 53 which is used by DNS.
Check out this KB article for details.
If port 53 is opened, but the issue is still there, please submit a ticket to Plesk Technical Support for further troubleshooting.
Thanks,
Kuzma
Hi Kuzma,
the Port 53 was not filtered and we could see in syslog that the request was incomming and reach the dns. But the dns
answered always with a denied or refused. We couldnt find the issue so that we switched back to debian 9. With that fresh Installation we have no dns Problems
Hello Betei Geuze,
Got it.
If you still want Plesk Support team to check why DNS was not working on your Debian 10 server, I'd suggest submit a ticket to Plesk Technical Support.
Hi
Same issue here. Debian 10 and Plesk 18.0.31.2 both will be freshly installed and DNS doesn't work. neither from localhost (servfail) than from external server (refused). We changed now to ubuntu, which works fine.
Regards
Armin
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