[FIXED BUG] Plesk or "yum update" system update fails: requires libMagickCore.so.5

Follow

Comments

5 comments

  • Avatar
    Christopher Danks

    HI

    I am using latest plesk Version 18.0.26 on CloudLinux 7.7

    when i do a yum clean all && yum update -y

    it still fails with:

     

    Error: Package: plesk-php74-imagick-3.4.3-1centos.7.200422.0947.x86_64 (PLESK_17_PHP74)
    Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64 (PLESK_17_PHP73)
    Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php56-imagick-3.1.2-centos7.20042209.x86_64 (PLESK_17_PHP56)
    Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php72-imagick-3.4.3-1centos.7.200427.1953.x86_64 (PLESK_17_PHP72)
    Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php71-imagick-3.4.3-1centos.7.200422.0938.x86_64 (PLESK_17_PHP71)
    Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php56-imagick-3.1.2-centos7.20042209.x86_64 (PLESK_17_PHP56)
    Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php72-imagick-3.4.3-1centos.7.200427.1953.x86_64 (PLESK_17_PHP72)
    Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64 (PLESK_17_PHP73)
    Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php70-imagick-3.4.3-centos7.20042209.x86_64 (PLESK_17_PHP70)
    Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php70-imagick-3.4.3-centos7.20042209.x86_64 (PLESK_17_PHP70)
    Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php74-imagick-3.4.3-1centos.7.200422.0947.x86_64 (PLESK_17_PHP74)
    Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php71-imagick-3.4.3-1centos.7.200422.0938.x86_64 (PLESK_17_PHP71)
    Requires: libMagickCore-6.Q16.so.6()(64bit)

    0
    Comment actions Permalink
  • Avatar
    Gregory Griffin

    Good Morning Ivan,

    TY for posting that the issue is fixed, but for me it's not as I still get the error as you see below:

    Error: Package: plesk-php74-imagick-3.4.3-1centos.7.200422.0947.x86_64 (PLESK_17_PHP74)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64 (PLESK_17_PHP73)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php56-imagick-3.1.2-centos7.20042209.x86_64 (PLESK_17_PHP56)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php71-imagick-3.4.3-1centos.7.200422.0938.x86_64 (PLESK_17_PHP71)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php56-imagick-3.1.2-centos7.20042209.x86_64 (PLESK_17_PHP56)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64 (PLESK_17_PHP73)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php70-imagick-3.4.3-centos7.20042209.x86_64 (PLESK_17_PHP70)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php70-imagick-3.4.3-centos7.20042209.x86_64 (PLESK_17_PHP70)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php74-imagick-3.4.3-1centos.7.200422.0947.x86_64 (PLESK_17_PHP74)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php71-imagick-3.4.3-1centos.7.200422.0938.x86_64 (PLESK_17_PHP71)
               Requires: libMagickCore-6.Q16.so.6()(64bit)

    How can I fix this? TY in advance for your help.

    I wish you a great day.

    BR

    Greg

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello,

    @Christopher Danks

    The fix for CloudLinux is expected to be available later this week. As a workaround, it is possible to update excluding ImageMagick from list of updates:

    # yum update --exclude=ImageMagick*

     

     

    @Gregory Griffin

    Try the same,e workaround.
    I will add it to the article for now.

    0
    Comment actions Permalink
  • Avatar
    Gregory Griffin

    Hi Igor,

    TY for the answer and suggestion.

    I tried it out and no go, on CentOS Linux 7.7.1908

    [root@ns359018 ~]# yum update --exclude=ImageMagick*
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Resolving Dependencies
    --> Running transaction check
    ---> Package plesk-php56-imagick.x86_64 0:3.1.2-centos7.18010913 will be updated
    ---> Package plesk-php56-imagick.x86_64 0:3.1.2-centos7.20042209 will be an update
    --> Processing Dependency: libMagickWand-6.Q16.so.6()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.20042209.x86_64
    --> Processing Dependency: libMagickCore-6.Q16.so.6()(64bit) for package: plesk-php56-imagick-3.1.2-centos7.20042209.x86_64
    ---> Package plesk-php70-imagick.x86_64 0:3.4.3-centos7.18021515 will be updated
    ---> Package plesk-php70-imagick.x86_64 0:3.4.3-centos7.20042209 will be an update
    --> Processing Dependency: libMagickWand-6.Q16.so.6()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.20042209.x86_64
    --> Processing Dependency: libMagickCore-6.Q16.so.6()(64bit) for package: plesk-php70-imagick-3.4.3-centos7.20042209.x86_64
    ---> Package plesk-php71-imagick.x86_64 0:3.4.3-1centos.7.190626.1727 will be updated
    ---> Package plesk-php71-imagick.x86_64 0:3.4.3-1centos.7.200422.0938 will be an update
    --> Processing Dependency: libMagickWand-6.Q16.so.6()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.200422.0938.x86_64
    --> Processing Dependency: libMagickCore-6.Q16.so.6()(64bit) for package: plesk-php71-imagick-3.4.3-1centos.7.200422.0938.x86_64
    ---> Package plesk-php73-imagick.x86_64 0:3.4.3-1centos.7.200418.1216 will be updated
    ---> Package plesk-php73-imagick.x86_64 0:3.4.3-1centos.7.200422.0945 will be an update
    --> Processing Dependency: libMagickWand-6.Q16.so.6()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64
    --> Processing Dependency: libMagickCore-6.Q16.so.6()(64bit) for package: plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64
    ---> Package plesk-php74-imagick.x86_64 0:3.4.3-1centos.7.200418.1216 will be updated
    ---> Package plesk-php74-imagick.x86_64 0:3.4.3-1centos.7.200422.0947 will be an update
    --> Processing Dependency: libMagickWand-6.Q16.so.6()(64bit) for package: plesk-php74-imagick-3.4.3-1centos.7.200422.0947.x86_64
    --> Processing Dependency: libMagickCore-6.Q16.so.6()(64bit) for package: plesk-php74-imagick-3.4.3-1centos.7.200422.0947.x86_64
    --> Finished Dependency Resolution
    Error: Package: plesk-php74-imagick-3.4.3-1centos.7.200422.0947.x86_64 (PLESK_17_PHP74)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64 (PLESK_17_PHP73)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php56-imagick-3.1.2-centos7.20042209.x86_64 (PLESK_17_PHP56)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php71-imagick-3.4.3-1centos.7.200422.0938.x86_64 (PLESK_17_PHP71)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php56-imagick-3.1.2-centos7.20042209.x86_64 (PLESK_17_PHP56)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php73-imagick-3.4.3-1centos.7.200422.0945.x86_64 (PLESK_17_PHP73)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php70-imagick-3.4.3-centos7.20042209.x86_64 (PLESK_17_PHP70)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php70-imagick-3.4.3-centos7.20042209.x86_64 (PLESK_17_PHP70)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
    Error: Package: plesk-php74-imagick-3.4.3-1centos.7.200422.0947.x86_64 (PLESK_17_PHP74)
               Requires: libMagickWand-6.Q16.so.6()(64bit)
    Error: Package: plesk-php71-imagick-3.4.3-1centos.7.200422.0938.x86_64 (PLESK_17_PHP71)
               Requires: libMagickCore-6.Q16.so.6()(64bit)
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    
    [root@ns359018 ~]#

     

    BR

    Greg

    0
    Comment actions Permalink
  • Avatar
    Alexey Lapshin

    Hello @Gregory Griffin,

    Please try the solution from this article: Unable to update Plesk: plesk-php* requires libMagickWand-6.Q16.so.6()(64bit)

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request