Plesk for Linux
kb: technical
ABT: Group B
Applicable to:
- Plesk for Linux
Symptoms
-
Mail for example.com is not received without any records in
/var/log/maillog
. - The following error can be found on the sender's side:
CONFIG_TEXT: connect to example.com[203.0.113.3]:25: Network is unreachable
Where 203.0.113.3 is the IP of ServerShield by Cloudflare extension. - Port 25 is open on the server:
# nmap -p 25 203.0.113.2 -Pn
PORT STATE SERVICE
25/tcp open smtp -
Domain example.com does not have MX record:
# dig MX example.com +short
#
Cause
Missing MX record for example.com
Resolution
If Plesk DNS server is used, add MX record for the domain using the article: How to add a DNS record for a domain in Plesk?
In case an external DNS server is used, it is required to add the appropriate MX records on the registrar's side using the article: How to configure mail in Plesk if DNS is hosted externally?
Note: It is required to wait for the DNS propagation period (up to 48 hours, but mostly faster).
Comments
1 comment
Inbox was huge (12GB), unable to open from webmail. Although already using plesk repair tool to fixed the mailbox.
Repairing the mail server configuration
Reconfiguring the mailboxes ..................................... [OK]
Error messages: 0; Warnings: 0; Errors resolved: 0
Please advice.
Please sign in to leave a comment.