Plesk for Windows
Plesk for Linux
kb: technical
ABT: Group B
Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
Unable to receive emails sent to a specific domain hosted on a Plesk server
Cause
The affected domain doesn't have a valid DNS MX record or DNS MX record is missing:
# dig @8.8.8.8 +short -t MX example.com +short
10 mail.
# dig @8.8.8.8 +short -t MX example.com +short
(Empty Output)
Resolution
Note: It is required to wait for the DNS propagation period (up to 48 hours, but mostly faster).
If Plesk DNS server is used, add a valid MX record for the affected domain: How to add a DNS record for a domain in Plesk?
If DNS records are managed externally, add the appropriate MX records on the registrar's side using the article: How to configure mail in Plesk if DNS is hosted externally?
Comments
1 comment
Inbox was huge (12GB), unable to open from webmail. Although already using plesk repair tool to fixed the mailbox.
Repairing the mail server configuration
Reconfiguring the mailboxes ..................................... [OK]
Error messages: 0; Warnings: 0; Errors resolved: 0
Please advice.
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